aboutsummaryrefslogtreecommitdiffstats
path: root/tests/setup.py
diff options
context:
space:
mode:
authorVijay VK <vv770d@att.com>2018-03-27 02:05:36 +0100
committerLadue, David (dl3158) <dl3158@att.com>2018-03-28 00:08:38 -0400
commit339ca1c5d3c9f138a13ae82c181b001df43645eb (patch)
tree8e7685bad1508786503dad76073e418c1dfc19fe /tests/setup.py
parente0b9a69c01845eb32baaf9029b1775b81d78906f (diff)
fix tox setup for snmptrap
Change-Id: I39adcd37cab64937af182c4716cba0cfaba6c7a2 Signed-off-by: VENKATESH KUMAR <vv770d@att.com> Issue-ID: DCAEGEN2-271 Signed-off-by: VENKATESH KUMAR <vv770d@att.com> Signed-off-by: Ladue, David (dl3158) <dl3158@att.com>
Diffstat (limited to 'tests/setup.py')
-rw-r--r--tests/setup.py73
1 files changed, 0 insertions, 73 deletions
diff --git a/tests/setup.py b/tests/setup.py
deleted file mode 100644
index 5a12f10..0000000
--- a/tests/setup.py
+++ /dev/null
@@ -1,73 +0,0 @@
-# org.onap.dcae
-# ================================================================================
-# Copyright (c) 2017-2018 AT&T Intellectual Property. All rights reserved.
-# ================================================================================
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-# ============LICENSE_END=========================================================
-#
-# ECOMP is a trademark and service mark of AT&T Intellectual Property.
-
-import argparse
-import array
-import asyncio
-import collections
-import datetime
-import errno
-import inspect
-import json
-import logging
-import logging.handlers
-import os
-import pprint
-import re
-import requests
-import signal
-import socket
-import string
-import sys
-import time
-import traceback
-import trapd_settings
-import trapd_settings as tds
-import unicodedata
-import uuid as uuid_mod
-from collections import Counter
-from onap_dcae_cbs_docker_client.client import get_config
-from pysnmp.carrier.asyncio.dgram import udp, udp6
-# from pysnmp.carrier.asyncore.dgram import udp
-from pysnmp.entity import engine, config
-from pysnmp.entity.rfc3413 import ntfrcv
-from pysnmp.proto.api import v2c
-from trapd_exit import cleanup_and_exit
-from trapd_file_utils import roll_all_logs, open_eelf_logs, roll_file, open_file, close_file
-from trapd_get_cbs_config import get_cbs_config
-from trapd_http_session import init_session_obj
-from trapd_logging import ecomp_logger, stdout_logger
-from trapd_logging import stdout_logger
-from trapd_runtime_pid import save_pid, rm_pid
-
-install_reqs = parse_requirements("requirements.txt", session=PipSession())
-reqs = [str(ir.req) for ir in install_reqs]
-
-setup(
- name = "dcaegen2-collectors-snmptrap",
- description = "snmp trap receiver for ONAP docker image",
- version = "1.3.0",
- packages=find_packages(),
- author = "Dave L",
- author_email = "dl3158@att.com",
- license='Apache 2',
- keywords = "",
- url = "",
- install_requires=reqs
-)