aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMichal Jagiello <michal.jagiello@t-mobile.pl>2021-01-15 13:04:54 +0000
committerJessica Wagantall <jwagantall@linuxfoundation.org>2021-02-12 17:21:50 +0000
commitaa6f2f2d4e2ffe842508f3de1e28d5a0ce2bf270 (patch)
treeaf9575e09b14812ac939d91b9690dead35cfaeaf /setup.py
parent603a6752e1e9514491740c274f91d09ed6fcdc59 (diff)
Bump pysnmp requirement version
Currently used pysnmp version can't be used with Python >= 3.7 version due to new keyword usage. Add py37, py38 and py39 envs into tox config. Added mvn-phase-lib locally to test python3 tox Issue-ID: DCAEGEN2-2494 Signed-off-by: Michal Jagiello <michal.jagiello@t-mobile.pl> Change-Id: I526ceb8d66b40b0a87f0ba688e1ed7f2e3e5b34f Signed-off-by: vv770d <vv770d@att.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py5
1 files changed, 3 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 4ce8c88..aab406b 100644
--- a/setup.py
+++ b/setup.py
@@ -1,6 +1,7 @@
# org.onap.dcae
# ================================================================================
# Copyright (c) 2017-2018 AT&T Intellectual Property. All rights reserved.
+# Copyright 2021 Deutsche Telekom. All rights reserved.
# ================================================================================
# Licensed under the Apache License, Version 2.0 (the "License");
# you may not use this file except in compliance with the License.
@@ -27,10 +28,10 @@ from setuptools import setup, find_packages
setup(
name = "snmptrap",
description = "snmp trap receiver for ONAP docker image",
- version = "2.0.3",
+ version = "2.0.4",
packages=find_packages(),
install_requires=[
- "pysnmp==4.4.2",
+ "pysnmp==4.4.12",
"requests==2.18.3",
"onap_dcae_cbs_docker_client==2.1.0"
],