summaryrefslogtreecommitdiffstats
path: root/dmaap/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'dmaap/setup.py')
-rw-r--r--dmaap/setup.py28
1 files changed, 24 insertions, 4 deletions
diff --git a/dmaap/setup.py b/dmaap/setup.py
index c423d95..7a4c85c 100644
--- a/dmaap/setup.py
+++ b/dmaap/setup.py
@@ -1,8 +1,26 @@
+# ============LICENSE_START====================================================
+# =============================================================================
+# Copyright (c) 2020 AT&T Intellectual Property. All rights reserved.
+# Copyright (c) 2020 Pantheon.tech. All rights reserved.
+# =============================================================================
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+# ============LICENSE_END======================================================
+
from setuptools import setup, find_packages
setup(
name = "dmaap",
- version = "1.3.5",
+ version = "1.4.0",
packages=find_packages(),
author = "AT&T",
description = ("Cloudify plugin for creating DMaaP feeds and topics, and setting up publishers and subscribers."),
@@ -10,7 +28,9 @@ setup(
keywords = "",
url = "",
zip_safe=False,
- install_requires = [
- "python-consul==0.7.0"
- ]
+ install_requires=[
+ 'python-consul>=0.7.0',
+ 'requests',
+ 'cloudify-common>=5.0.5',
+ ],
)