summaryrefslogtreecommitdiffstats
path: root/dnsdesig/pom.xml
diff options
context:
space:
mode:
authorAndrew Gauld <ag1282@att.com>2018-02-22 14:55:37 -0500
committerAndrew Gauld <ag1282@att.com>2018-02-22 14:56:35 -0500
commit6e6babd96b389602e6ab4b3550a0c3db4f9ae7c6 (patch)
treeeaadd3605e818063bf492b71a079b0c0aa4ecc87 /dnsdesig/pom.xml
parentd154b4c606f4af5873676fed4bea39f8b91adee6 (diff)
Make SONAR code coverage work
Change-Id: Id54f9199d4ac7a1a501a875743fa35aecbe60ac4 Issue-ID: DCAEGEN2-355 Signed-off-by: Andrew Gauld <ag1282@att.com>
Diffstat (limited to 'dnsdesig/pom.xml')
-rw-r--r--dnsdesig/pom.xml13
1 files changed, 3 insertions, 10 deletions
diff --git a/dnsdesig/pom.xml b/dnsdesig/pom.xml
index 9306540..2d96e81 100644
--- a/dnsdesig/pom.xml
+++ b/dnsdesig/pom.xml
@@ -44,19 +44,12 @@ limitations under the License.
<typefile.dest>type_files/dnsdesig/dns_types.yaml</typefile.dest>
<project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
<sonar.sources>.</sonar.sources>
- <!-- customize the SONARQUBE URL -->
- <sonar.host.url>http://localhost:9000</sonar.host.url>
- <!-- below are language dependent -->
- <!-- for Python -->
+ <sonar.junit.reportsPath>xunit-results.xml</sonar.junit.reportsPath>
+ <sonar.python.coverage.reportPath>coverage.xml</sonar.python.coverage.reportPath>
<sonar.language>py</sonar.language>
<sonar.pluginName>Python</sonar.pluginName>
<sonar.inclusions>**/*.py</sonar.inclusions>
- <!-- for JavaScaript -->
- <!--
- <sonar.language>js</sonar.language>
- <sonar.pluginName>JS</sonar.pluginName>
- <sonar.inclusions>**/*.js</sonar.inclusions>
- -->
+ <sonar.exclusions>tests/*,setup.py</sonar.exclusions>
</properties>
<build>