Age | Commit message (Collapse) | Author | Files | Lines |
|
Change-Id: I34451fbebbe7bbaaf1cd23aed5cef0f9a9ba37b7
Issues-Id: CCSDK-111
Signed-off-by: Nicolas Hu <jh245g@att.com>
|
|
|
|
Major sonar issue in dashboard module
*Using collection.isEmpty() instead of collection.size()
makes code more readable and is more performant
Issue-Id: CCSDK-87
Change-Id: I201d1c7982ce6a1509a462d7d151a41ab2912f91
Signed-off-by: surya-huawei <a.u.surya@huawei.com>
|
|
code refactoring and exception handling
Issue-Id: CCSDK-87
Change-Id: I5440c1102dfa8a00a7813107cd3ab967b4316529
Signed-off-by: Bharat saraswal <bharat.saraswal@huawei.com>
|
|
Few major issues
*Making anonymous inner class a lambda
This increases code readability
*Replace the type specification with the diamond operator
This reduces the verbosity of generics code
Issue-Id: CCSDK-87
Change-Id: Ia527040781af3a3d006486f3d73416f2f5e288cc
Signed-off-by: surya-huawei <a.u.surya@huawei.com>
|
|
few major issues in dashboard module
In CustomLogginFilter.java
*move string literal to left side of equalsIgnoreCase method
In DashboardRestricedBaseController.java
*Use "Boolean.parseBoolean" for this string-to-boolean conversion
In ECDSingleSignOnController.java
*Replace the type specification in this constructor call with the diamond operator
*Add the "@Override" annotation above this method signature
*Remove unnecessary type casting
Issue-Id: CCSDK-87
Change-Id: I2d588c29c4c57394f7b4a8ffcb20567cbb515919
Signed-off-by: surya-huawei <a.u.surya@huawei.com>
|
|
- Change to OOM Dashboard (no more ECOMP Controller)
- Rework some exception handling
Issue: CCSDK-61
Change-Id: Id5379e8b272b651373c79f46b20da1d32de013ed
Signed-off-by: Christopher Lott (cl778h) <clott@research.att.com>
|