aboutsummaryrefslogtreecommitdiffstats
path: root/SoftHSMv2/src/lib/slot_mgr/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'SoftHSMv2/src/lib/slot_mgr/Makefile.am')
-rw-r--r--SoftHSMv2/src/lib/slot_mgr/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/SoftHSMv2/src/lib/slot_mgr/Makefile.am b/SoftHSMv2/src/lib/slot_mgr/Makefile.am
new file mode 100644
index 0000000..1e8cf33
--- /dev/null
+++ b/SoftHSMv2/src/lib/slot_mgr/Makefile.am
@@ -0,0 +1,18 @@
+MAINTAINERCLEANFILES = $(srcdir)/Makefile.in
+
+AM_CPPFLAGS = -I$(srcdir)/.. \
+ -I$(srcdir)/../common \
+ -I$(srcdir)/../crypto \
+ -I$(srcdir)/../data_mgr \
+ -I$(srcdir)/../object_store \
+ -I$(srcdir)/../pkcs11 \
+ -I$(srcdir)/../session_mgr
+
+noinst_LTLIBRARIES = libsofthsm_slotmgr.la
+libsofthsm_slotmgr_la_SOURCES = SlotManager.cpp \
+ Slot.cpp \
+ Token.cpp
+
+SUBDIRS = test
+
+EXTRA_DIST = $(srcdir)/*.h