aboutsummaryrefslogtreecommitdiffstats
path: root/SoftHSMv2/src/lib/handle_mgr/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'SoftHSMv2/src/lib/handle_mgr/Makefile.am')
-rw-r--r--SoftHSMv2/src/lib/handle_mgr/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/SoftHSMv2/src/lib/handle_mgr/Makefile.am b/SoftHSMv2/src/lib/handle_mgr/Makefile.am
new file mode 100644
index 0000000..108f74d
--- /dev/null
+++ b/SoftHSMv2/src/lib/handle_mgr/Makefile.am
@@ -0,0 +1,17 @@
+MAINTAINERCLEANFILES = $(srcdir)/Makefile.in
+
+AM_CPPFLAGS = -I$(srcdir)/.. \
+ -I$(srcdir)/../common \
+ -I$(srcdir)/../crypto \
+ -I$(srcdir)/../data_mgr \
+ -I$(srcdir)/../object_store \
+ -I$(srcdir)/../pkcs11 \
+ -I$(srcdir)/../slot_mgr
+
+noinst_LTLIBRARIES = libsofthsm_handlemgr.la
+libsofthsm_handlemgr_la_SOURCES = HandleManager.cpp \
+ Handle.cpp
+
+SUBDIRS = test
+
+EXTRA_DIST = $(srcdir)/*.h