aboutsummaryrefslogtreecommitdiffstats
path: root/SoftHSMv2/src/lib/data_mgr/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'SoftHSMv2/src/lib/data_mgr/Makefile.am')
-rw-r--r--SoftHSMv2/src/lib/data_mgr/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/SoftHSMv2/src/lib/data_mgr/Makefile.am b/SoftHSMv2/src/lib/data_mgr/Makefile.am
new file mode 100644
index 0000000..85aa4d7
--- /dev/null
+++ b/SoftHSMv2/src/lib/data_mgr/Makefile.am
@@ -0,0 +1,17 @@
+MAINTAINERCLEANFILES = $(srcdir)/Makefile.in
+
+AM_CPPFLAGS = -I$(srcdir)/.. \
+ -I$(srcdir)/../crypto \
+ -I$(srcdir)/../common \
+ -I$(srcdir)/../pkcs11
+
+noinst_LTLIBRARIES = libsofthsm_datamgr.la
+libsofthsm_datamgr_la_SOURCES = ByteString.cpp \
+ RFC4880.cpp \
+ salloc.cpp \
+ SecureDataManager.cpp \
+ SecureMemoryRegistry.cpp
+
+SUBDIRS = test
+
+EXTRA_DIST = $(srcdir)/*.h