aboutsummaryrefslogtreecommitdiffstats
path: root/TPM2-Plugin/lib/Makefile.am
diff options
context:
space:
mode:
authorNingSun <ning.sun@intel.com>2018-03-29 21:06:26 -0700
committerNingSun <ning.sun@intel.com>2018-03-29 22:51:26 -0700
commit337e67515bb081df614ae7e8313c904499e3505f (patch)
treeffe24fbd9a44a618b267e1be4f584d77a830925e /TPM2-Plugin/lib/Makefile.am
parent4ba28823277dd1d154e4a26f7eae440c40b1f9fd (diff)
Clean up TPM2 PLugin codes
Remove unused and redundant codes. Issue-ID: AAF-94 Change-Id: Icfdbf29e2d7caa339977e7d074f16e123cbff84f Signed-off-by: NingSun <ning.sun@intel.com>
Diffstat (limited to 'TPM2-Plugin/lib/Makefile.am')
-rw-r--r--TPM2-Plugin/lib/Makefile.am5
1 files changed, 2 insertions, 3 deletions
diff --git a/TPM2-Plugin/lib/Makefile.am b/TPM2-Plugin/lib/Makefile.am
index 26689a7..ed5f3c0 100644
--- a/TPM2-Plugin/lib/Makefile.am
+++ b/TPM2-Plugin/lib/Makefile.am
@@ -1,5 +1,4 @@
-AM_CPPFLAGS = -I ./include
+AM_CPPFLAGS = -I ./include -I /opt/openssl
lib_LTLIBRARIES = libtpm2-plugin.la
-libtpm2_plugin_la_SOURCES = tpm2_error.c tpm2_plugin_api.c tpm2_plugin_init.c tpm2_tcti_ldr.c tpm2_util.c log.c plugin_register.c files.c tpm2_attr_util.c tpm2_alg_util.c tpm2_hash.c tpm2_convert.c
-#libtpm2_plugin_la_LDFLAGS = -version-info @VERSION_INFO@ -lsapi -ltss2 -ltcti-socket -ltcti-device -lcrypto -lssl -ldl
+libtpm2_plugin_la_SOURCES = tpm2_error.c tpm2_plugin_api.c tpm2_plugin_init.c tpm2_tcti_ldr.c tpm2_util.c log.c files.c tpm2_attr_util.c tpm2_alg_util.c tpm2_hash.c tpm2_convert.c
libtpm2_plugin_la_LDFLAGS = -version-info @VERSION_INFO@ -lsapi -ltss2-mu -ltcti-socket -ltcti-device -lcrypto -lssl -ldl