aboutsummaryrefslogtreecommitdiffstats
path: root/SoftHSMv2/src/lib/Makefile.am
diff options
context:
space:
mode:
authorNingSun <ning.sun@intel.com>2018-02-08 08:34:03 -0800
committerNingSun <ning.sun@intel.com>2018-02-08 09:14:52 -0800
commit0c89b3ccba7c9b7332ab67ae1936aff51ca62367 (patch)
tree70c1b1d160d4c6d0a83395ca9a87c1264d0d3439 /SoftHSMv2/src/lib/Makefile.am
parent945613b4db4e07f75d2bc7463db580ddfaa700fd (diff)
Initial sshsm project structure
Issue-ID: AAF-94 Change-Id: I5e82fff418e7567b161acf9b98013a9b85ffc5b4 Signed-off-by: NingSun <ning.sun@intel.com>
Diffstat (limited to 'SoftHSMv2/src/lib/Makefile.am')
-rw-r--r--SoftHSMv2/src/lib/Makefile.am52
1 files changed, 52 insertions, 0 deletions
diff --git a/SoftHSMv2/src/lib/Makefile.am b/SoftHSMv2/src/lib/Makefile.am
new file mode 100644
index 0000000..f3f5bb4
--- /dev/null
+++ b/SoftHSMv2/src/lib/Makefile.am
@@ -0,0 +1,52 @@
+MAINTAINERCLEANFILES = $(srcdir)/Makefile.in
+
+AM_CPPFLAGS = -I$(srcdir)/common \
+ -I$(srcdir)/crypto \
+ -I$(srcdir)/data_mgr \
+ -I$(srcdir)/handle_mgr \
+ -I$(srcdir)/object_store \
+ -I$(srcdir)/pkcs11 \
+ -I$(srcdir)/session_mgr \
+ -I$(srcdir)/slot_mgr \
+ @CRYPTO_INCLUDES@
+
+lib_LTLIBRARIES = libsofthsm2.la
+
+libsofthsm2_la_SOURCES = access.cpp \
+ main.cpp \
+ P11Attributes.cpp \
+ P11Objects.cpp \
+ SoftHSM.cpp
+libsofthsm2_la_LIBADD = common/libsofthsm_common.la \
+ crypto/libsofthsm_crypto.la \
+ data_mgr/libsofthsm_datamgr.la \
+ handle_mgr/libsofthsm_handlemgr.la \
+ object_store/libsofthsm_objectstore.la \
+ session_mgr/libsofthsm_sessionmgr.la \
+ slot_mgr/libsofthsm_slotmgr.la
+libsofthsm2_la_LDFLAGS = -version-info @VERSION_INFO@ \
+ -avoid-version -module
+
+# Create a convenience library from all the other convenience library; this is
+# necessary to resolve circular dependencies when statically linking the test
+# executables
+noinst_LTLIBRARIES = libsofthsm_convarch.la
+
+libsofthsm_convarch_la_SOURCES =
+
+libsofthsm_convarch_la_LIBADD = $(libsofthsm2_la_LIBADD)
+
+SUBDIRS = common \
+ crypto \
+ data_mgr \
+ object_store \
+ session_mgr \
+ slot_mgr \
+ handle_mgr \
+ test
+
+EXTRA_DIST = $(srcdir)/*.h \
+ $(srcdir)/pkcs11/*.h \
+ $(srcdir)/win32/*.cc \
+ $(srcdir)/win32/*.cpp \
+ $(srcdir)/win32/*.h