aboutsummaryrefslogtreecommitdiffstats
path: root/SoftHSMv2/src/bin/keyconv/Makefile.am
diff options
context:
space:
mode:
authorRitu Sood <ritu.sood@intel.com>2018-05-09 07:04:42 +0000
committerKiran Kamineni <kiran.k.kamineni@intel.com>2018-05-10 03:59:53 +0000
commit1432266ea7ce545a60b0b53f4c920e68bc1ed152 (patch)
treebf54ff0fd820c7f3027d029f37d1c86b2655d4c8 /SoftHSMv2/src/bin/keyconv/Makefile.am
parent7793a619f0fe6a879221e675249cccc632216a11 (diff)
Remove keyconv code from SoftHSM library
Code not used by SoftHsm and has license issues Issue-ID: AAF-279 Change-Id: Ie07eef82f9e7bcc445772dba474c1f0e7753542c Signed-off-by: Ritu Sood <ritu.sood@intel.com>
Diffstat (limited to 'SoftHSMv2/src/bin/keyconv/Makefile.am')
-rw-r--r--SoftHSMv2/src/bin/keyconv/Makefile.am26
1 files changed, 0 insertions, 26 deletions
diff --git a/SoftHSMv2/src/bin/keyconv/Makefile.am b/SoftHSMv2/src/bin/keyconv/Makefile.am
deleted file mode 100644
index b4268c2..0000000
--- a/SoftHSMv2/src/bin/keyconv/Makefile.am
+++ /dev/null
@@ -1,26 +0,0 @@
-MAINTAINERCLEANFILES = $(srcdir)/Makefile.in
-
-AM_CPPFLAGS = -I$(srcdir)/../../lib/crypto \
- @CRYPTO_INCLUDES@
-
-dist_man_MANS = softhsm2-keyconv.1
-
-bin_PROGRAMS = softhsm2-keyconv
-
-softhsm2_keyconv_SOURCES = softhsm2-keyconv.cpp \
- base64.c
-softhsm2_keyconv_LDADD = @CRYPTO_LIBS@
-
-# Compile with OpenSSL support
-if WITH_OPENSSL
-softhsm2_keyconv_SOURCES += softhsm2-keyconv-ossl.cpp \
- ../../lib/crypto/OSSLComp.cpp
-endif
-
-# Compile with Botan support
-if WITH_BOTAN
-softhsm2_keyconv_SOURCES += softhsm2-keyconv-botan.cpp
-endif
-
-EXTRA_DIST = $(srcdir)/*.h \
- $(srcdir)/*.cpp