summaryrefslogtreecommitdiffstats
path: root/sms-client/python/onap-sms-client/setup.py
diff options
context:
space:
mode:
authorDileep Ranganathan <dileep.ranganathan@intel.com>2018-09-05 06:43:30 -0700
committerDileep Ranganathan <dileep.ranganathan@intel.com>2018-09-07 03:24:33 -0700
commit65a823163f1e59d6dedd812da3782423f93c20fa (patch)
tree71abe38270ed3eec424119e901657786beb9de5d /sms-client/python/onap-sms-client/setup.py
parent6546bbac701bdff45adb11c7e93236e6736898f6 (diff)
Create python distribution for onap-sms-client
Renamed to onap-sms-client to conform to standard packaging Created and uploaded onap-sms-client python distribution to PyPI This will allow onapsmsclient to be installed using pip. Change-Id: I8ab1137fce5dbb022d54a2c96bc3acdc97d7e63d Issue-ID: AAF-438 Signed-off-by: Dileep Ranganathan <dileep.ranganathan@intel.com>
Diffstat (limited to 'sms-client/python/onap-sms-client/setup.py')
-rw-r--r--sms-client/python/onap-sms-client/setup.py36
1 files changed, 36 insertions, 0 deletions
diff --git a/sms-client/python/onap-sms-client/setup.py b/sms-client/python/onap-sms-client/setup.py
new file mode 100644
index 0000000..2adebc7
--- /dev/null
+++ b/sms-client/python/onap-sms-client/setup.py
@@ -0,0 +1,36 @@
+# Copyright 2018 Intel Corporation, Inc
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+
+from setuptools import setup, find_packages
+
+setup(
+
+ name='onap-sms-client',
+ keywords=("secret", "consul", "onap"),
+ description="ONAP python SMS client library",
+ long_description="python-package onap-sms-client client library for using"
+ " Secret Management Service (SMS) inside ONAP. Refer "
+ "https://wiki.onap.org/display/DW/Secret+Management+Service for more details.",
+ version="0.0.1",
+ url="https://gerrit.onap.org/r/gitweb?p=aaf%2Fsms.git;a=summary",
+ license="Apache 2",
+ author="Kiran Kamineni",
+ packages=find_packages(),
+ platforms=["all"],
+ classifiers=[
+ "Intended Audience :: Developers",
+ "Programming Language :: Python :: 2.7"
+ ]
+)