aboutsummaryrefslogtreecommitdiffstats
path: root/onap-client/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'onap-client/setup.py')
-rw-r--r--onap-client/setup.py65
1 files changed, 65 insertions, 0 deletions
diff --git a/onap-client/setup.py b/onap-client/setup.py
new file mode 100644
index 0000000..a80f832
--- /dev/null
+++ b/onap-client/setup.py
@@ -0,0 +1,65 @@
+# -*- coding: utf8 -*-
+# ============LICENSE_START=======================================================
+# org.onap.vvp/validation-scripts
+# ===================================================================
+# Copyright © 2020 AT&T Intellectual Property. All rights reserved.
+# ===================================================================
+#
+# Unless otherwise specified, all software contained herein is licensed
+# under the Apache License, Version 2.0 (the "License");
+# you may not use this software except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+#
+#
+# Unless otherwise specified, all documentation contained herein is licensed
+# under the Creative Commons License, Attribution 4.0 Intl. (the "License");
+# you may not use this documentation except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# https://creativecommons.org/licenses/by/4.0/
+#
+# Unless required by applicable law or agreed to in writing, documentation
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+# ============LICENSE_END============================================
+
+import setuptools
+import os
+
+with open("README.md", "r") as fh:
+ long_description = fh.read()
+
+datafiles = [("onap_client", ["etc/config.example.yaml"])]
+for file in os.listdir("etc/payloads"):
+ datafiles.append(("onap_client/payloads", ["etc/payloads/{}".format(file)]))
+
+setuptools.setup(
+ name="onap-client",
+ version="0.1.0",
+ author="Steven Stark",
+ author_email="steven.stark@att.com",
+ description="Python API wrapper for ONAP applications",
+ long_description=long_description,
+ long_description_content_type="text/markdown",
+ packages=setuptools.find_packages(),
+ classifiers=[
+ "Programming Language :: Python :: 3",
+ "License :: OSI Approved :: MIT License",
+ "Operating System :: OS Independent",
+ ],
+ python_requires=">=3.6",
+ scripts=["bin/onap-client"],
+ data_files=datafiles,
+)