aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py77
1 files changed, 77 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..ae350cb
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,77 @@
+#!/usr/bin/env python
+
+#
+# Copyright (c) 2016-2017 GigaSpaces Technologies Ltd. All rights reserved.
+#
+# Licensed under the Apache License, Version 2.0 (the "License"); you may
+# not use this file except in compliance with the License. You may obtain
+# a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS, WITHOUT
+# WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the
+# License for the specific language governing permissions and limitations
+# under the License.
+#
+
+from setuptools import setup
+import sys
+
+if sys.version_info < (2, 7):
+ sys.exit('VNF SDK requires Python 2.7+')
+if sys.version_info >= (3, 0):
+ sys.exit('VNF SDK does not support Python 3')
+
+setup(
+ name='vnfsdk',
+ version='0.1',
+ description='VNF SDK CSAR package tool',
+ license='Apache License Version 2.0',
+
+ author='GigaSpaces',
+ author_email='info@gigaspaces.com',
+
+ url='http://open-o.org/',
+
+ classifiers=[
+ 'Development Status :: 4 - Beta',
+ 'Environment :: Console',
+ 'Environment :: Web Environment',
+ 'Intended Audience :: Developers',
+ 'Intended Audience :: System Administrators',
+ 'License :: OSI Approved :: Apache Software License',
+ 'Operating System :: OS Independent',
+ 'Programming Language :: Python',
+ 'Topic :: Software Development :: Libraries :: Python Modules',
+ 'Topic :: System :: Networking',
+ 'Topic :: System :: Systems Administration'],
+
+ packages=[
+ 'packager',
+ 'cli'
+ ],
+
+ package_dir={
+ 'packager': 'packager',
+ 'cli': 'cli',
+ },
+
+ entry_points={
+ 'console_scripts': [
+ 'vnfsdk = cli.__main__:main']
+ },
+ # Please make sure this is in sync with src/aria/requirements.txt
+ install_requires=[
+ 'ruamel.yaml==0.12.14',
+ 'requests',
+ 'logging',
+ 'clint==0.5.1',
+ 'CacheControl[filecache]==0.11.6',
+ 'lockfile',
+ 'Jinja2==2.8',
+ 'shortuuid==0.4.3',
+ 'jsonpickle',
+ 'aria == 0.1'])
+