aboutsummaryrefslogtreecommitdiffstats
path: root/pom.xml
diff options
context:
space:
mode:
authorLianhao Lu <lianhao.lu@intel.com>2018-03-22 20:39:04 +0800
committerLianhao Lu <lianhao.lu@intel.com>2018-03-22 20:54:00 +0800
commit7676ca5e12557f72226fac162e5f1530964906cb (patch)
tree8659c0036c8dbbdeca02d186ec28f37b87fec401 /pom.xml
parentc3fe9827d9357f5fa2a62f6f0965ad40106a5aad (diff)
Adjusted for pypi support
We need to adjust the python module structure meet the pypi requirements. This has been tested on test pypi https://test.pypi.org/project/vnfsdk. 1. move 3 directories cli/ validator/ packager/ into vnfsdk_pkgtools. so now the python module for vnfsdk pkgtools would be "vnfsdk_pkgtool.*" 2. Added missing README.rst, LICENSE.txt according to pypi requirement. 3. Added new version mechanism accroding onap community suggestions. 4. Other clean sweep job like dos2unix. Change-Id: If90df33673bff045d85d67c29a1d0ab44d0c8858 Issue-ID: VNFSDK-143 Signed-off-by: Lianhao Lu <lianhao.lu@intel.com>
Diffstat (limited to 'pom.xml')
-rw-r--r--pom.xml4
1 files changed, 2 insertions, 2 deletions
diff --git a/pom.xml b/pom.xml
index 413f2d8..a64eff7 100644
--- a/pom.xml
+++ b/pom.xml
@@ -33,13 +33,13 @@ under the License.
<description>CSAR manipulation shared library with CLI</description>
<properties>
<sonar.sourceEncoding>UTF-8</sonar.sourceEncoding>
- <sonar.sources>cli,packager,validator</sonar.sources>
+ <sonar.sources>vnfsdk_pkgtools</sonar.sources>
<sonar.tests>tests</sonar.tests>
<sonar.junit.reportsPath>xunit-results.xml</sonar.junit.reportsPath>
<sonar.python.coverage.reportPath>coverage.xml</sonar.python.coverage.reportPath>
<sonar.language>py</sonar.language>
<sonar.pluginName>python</sonar.pluginName>
- <sonar.inclusions>cli/**.py,packager/**.py,validator/**.py</sonar.inclusions>
+ <sonar.inclusions>vnfsdk_pkgtools/**.py</sonar.inclusions>
<sonar.exclusions>**/tests/**,**/.tox/py27/**</sonar.exclusions>
<sonar.test.inclusions>**/tests/**.py</sonar.test.inclusions>
<sonar.test.exclusions>setup.py,.tox/py27/**</sonar.test.exclusions>