diff options
author | Moshe <moshehoa@amdocs.com> | 2018-03-28 19:38:05 +0300 |
---|---|---|
committer | Moshe <moshehoa@amdocs.com> | 2018-03-28 20:07:24 +0300 |
commit | e4c31a3b9f7fa0f7da935f985a9f47bccb1b00d4 (patch) | |
tree | 1e887dec1a19936713abecd23ca02e7b3e4cf152 /pom.xml | |
parent | 4391bbd783c9ca51eef7883b61292ff1b1beba7c (diff) |
Add docker handling to pom
Issue-ID: VNFSDK-183
Change-Id: If1e733958e874a0297da5753d8ec066281c4bdb9
Signed-off-by: Moshe <moshehoa@amdocs.com>
Diffstat (limited to 'pom.xml')
-rw-r--r-- | pom.xml | 75 |
1 files changed, 75 insertions, 0 deletions
@@ -36,6 +36,81 @@ under the License. <sonar.inclusions>**/*.py</sonar.inclusions> <sonar.skip>false</sonar.skip> <sonar.exclusions>version.py,setup.py</sonar.exclusions> + + <maven.build.timestamp.format>yyyyMMdd-HHmm</maven.build.timestamp.format> + <docker.push.registry></docker.push.registry> + <skip.docker.build>true</skip.docker.build> + <skip.docker.tag>true</skip.docker.tag> + <skip.docker.push>true</skip.docker.push> + <docker.skip>false</docker.skip> + <docker.skip.build>false</docker.skip.build> </properties> + <profiles> + <profile> + <id>docker</id> + <activation> + <activeByDefault>false</activeByDefault> + </activation> + <build> + <plugins> + <plugin> + <groupId>io.fabric8</groupId> + <artifactId>docker-maven-plugin</artifactId> + <version>0.16.7</version> + <configuration> + <verbose>true</verbose> + <apiVersion>1.23</apiVersion> + <skipDocker>${docker.skip}</skipDocker> + <images> + <image> + <name>onap/vnfsdk/vnftest</name> + <alias>vnftest</alias> + <build> + <cleanup>try</cleanup> + <dockerFileDir>${project.basedir}/docker</dockerFileDir> + </build> + </image> + </images> + </configuration> + <executions> + <execution> + <id>clean-images</id> + <phase>pre-clean</phase> + <goals> + <goal>remove</goal> + </goals> + <configuration> + <removeAll>true</removeAll> + <image>onap/vnfsdk/vnftest</image> + </configuration> + </execution> + + <execution> + <id>generate-images</id> + <phase>generate-sources</phase> + <goals> + <goal>build</goal> + </goals> + <configuration> + <skipDockerBuild>${docker.skip.build}</skipDockerBuild> + </configuration> + </execution> + <execution> + <id>push-images</id> + <phase>deploy</phase> + <goals> + <goal>build</goal> + <goal>push</goal> + </goals> + <configuration> + <image>onap/vnfsdk/vnftest</image> + </configuration> + </execution> + </executions> + </plugin> + </plugins> + </build> + </profile> + </profiles> </project> |