summaryrefslogtreecommitdiffstats
path: root/pom.xml
diff options
context:
space:
mode:
authorMoshe <moshehoa@amdocs.com>2018-03-25 17:00:40 +0300
committerMoshe <moshehoa@amdocs.com>2018-03-25 18:07:32 +0300
commitea90f9ba9d0e317dfc5521dda9946844b7336abd (patch)
tree24b8d699b7d8166f9b8597d1f72c4557db3906bf /pom.xml
parent583448a180e36b5b406fa9542392ea0400914700 (diff)
Add unit tests and handle coverage
Issue-ID: VNFSDK-183 Change-Id: I228576f5c06b371164bcd653d23cf169098436a8 Signed-off-by: Moshe <moshehoa@amdocs.com> handle coverage Issue-ID: VNFSDK-183 Change-Id: I3d78293fdf5cb8bc57caa4078ab8fa5baa429a0d Signed-off-by: Moshe <moshehoa@amdocs.com>
Diffstat (limited to 'pom.xml')
-rw-r--r--pom.xml4
1 files changed, 3 insertions, 1 deletions
diff --git a/pom.xml b/pom.xml
index a10c63d..bc11b62 100644
--- a/pom.xml
+++ b/pom.xml
@@ -20,7 +20,6 @@ under the License.
<groupId>org.onap.oparent</groupId>
<artifactId>oparent</artifactId>
<version>1.1.0</version>
- <relativePath>../oparent</relativePath>
</parent>
<groupId>org.onap.vnfsdk.dovetail-integration</groupId>
@@ -30,10 +29,13 @@ under the License.
<name>vnfsdk-dovetail-integration</name>
<description>Integration with OPNFV Dovetail project</description>
<properties>
+ <sonar.sources>.</sonar.sources>
+ <sonar.python.coverage.reportPath>coverage.xml</sonar.python.coverage.reportPath>
<sonar.language>py</sonar.language>
<sonar.pluginName>Python</sonar.pluginName>
<sonar.inclusions>**/*.py</sonar.inclusions>
<sonar.skip>false</sonar.skip>
+ <sonar.exclusions>version.py,setup.py</sonar.exclusions>
</properties>
</project>