diff options
author | ying.yunlong <ying.yunlong@zte.com.cn> | 2018-03-02 16:10:37 +0800 |
---|---|---|
committer | ying.yunlong <ying.yunlong@zte.com.cn> | 2018-03-02 16:10:37 +0800 |
commit | 53074686f083ca91043acb16cb04fd9d115099c5 (patch) | |
tree | 3766aefc0029bc06ad1b4606dd17187ae44d0e98 /pom.xml | |
parent | 37b7ddf7ed867a55cad7fcfe33cef16abd3f709a (diff) |
Fix vfc-vnfmgr sonar job failure
Change-Id: Ib91b65bf609a2d5b6b4526e3ec7f0637746768b7
Issue-ID: VFC-786
Signed-off-by: ying.yunlong <ying.yunlong@zte.com.cn>
Diffstat (limited to 'pom.xml')
-rw-r--r-- | pom.xml | 83 |
1 files changed, 83 insertions, 0 deletions
@@ -26,8 +26,91 @@ <version>1.1.0-SNAPSHOT</version> <packaging>pom</packaging> <name>vfc-gvnfm-vnfmgr</name> + <properties> + <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding> + <sonar.sources>.</sonar.sources> + <sonar.junit.reportsPath>xunit-results.xml</sonar.junit.reportsPath> + <sonar.python.coverage.reportPath>coverage.xml</sonar.python.coverage.reportPath> + <sonar.language>py</sonar.language> + <sonar.pluginname>python</sonar.pluginname> + <sonar.inclusions>**/**.py</sonar.inclusions> + <sonar.exclusions>**/tests/**.py,**/test*.py,**/__init__.py,setup.py</sonar.exclusions> + </properties> <description>vfc gvnfm vnfmgr</description> <modules> <module>mgr</module> </modules> + <build> + <pluginManagement> + <plugins> + <plugin> + <groupId>org.codehaus.mojo</groupId> + <artifactId>exec-maven-plugin</artifactId> + <version>1.2.1</version> + <configuration> + <executable>${session.executionRootDirectory}/mvn-phase-script.sh</executable> + <environmentVariables> + <!-- make mvn properties as env for our script --> + <MVN_PROJECT_GROUPID>${project.groupId}</MVN_PROJECT_GROUPID> + <MVN_PROJECT_ARTIFACTID>${project.artifactId}</MVN_PROJECT_ARTIFACTID> + <MVN_PROJECT_VERSION>${project.version}</MVN_PROJECT_VERSION> + </environmentVariables> + </configuration> + </plugin> + </plugins> + </pluginManagement> + <plugins> + <plugin> + <groupId>org.codehaus.mojo</groupId> + <artifactId>exec-maven-plugin</artifactId> + <version>1.2.1</version> + <executions> + <execution> + <id>clean phase script</id> + <phase>clean</phase> + <goals> + <goal>exec</goal> + </goals> + <configuration> + <arguments> + <argument>__</argument> + <argument>clean</argument> + </arguments> + </configuration> + </execution> + <execution> + <id>test script</id> + <phase>test</phase> + <goals> + <goal>exec</goal> + </goals> + <configuration> + <arguments> + <argument>__</argument> + <argument>test</argument> + </arguments> + </configuration> + </execution> + </executions> + </plugin> + <plugin> + <artifactId>maven-assembly-plugin</artifactId> + <configuration> + <appendAssemblyId>false</appendAssemblyId> + <descriptors> + <descriptor>assembly.xml</descriptor> + </descriptors> + </configuration> + <executions> + <execution> + <id>make-assembly</id> + <phase>package</phase> + <goals> + <goal>single</goal> + </goals> + </execution> + </executions> + </plugin> + </plugins> + </build> </project> |