summaryrefslogtreecommitdiffstats
path: root/lcm/pom.xml
diff options
context:
space:
mode:
authorying.yunlong <ying.yunlong@zte.com.cn>2018-03-02 11:01:11 +0800
committeryunlong ying <ying.yunlong@zte.com.cn>2018-03-03 03:53:21 +0000
commit838f2ded9478ae140545fcdceb4cc10d73a2c92b (patch)
tree8512a8560c2f150002f7dd229a025dacaf5c2159 /lcm/pom.xml
parentadbda5b9c0365eae74b1c37d37c0e960eb1828ad (diff)
Add vfc-vnflcm coverage scan.
Change-Id: I62b3a3982ff1b40cb31a2187c85fe72af9be7791 Issue-ID: VFC-781 Signed-off-by: ying.yunlong <ying.yunlong@zte.com.cn>
Diffstat (limited to 'lcm/pom.xml')
-rw-r--r--lcm/pom.xml61
1 files changed, 61 insertions, 0 deletions
diff --git a/lcm/pom.xml b/lcm/pom.xml
index 8b323d2c..a94adf6f 100644
--- a/lcm/pom.xml
+++ b/lcm/pom.xml
@@ -26,10 +26,71 @@
<version>1.1.0-SNAPSHOT</version>
<packaging>pom</packaging>
<name>vfc/gvnfm/vnflcm/lcm</name>
+ <properties>
+ <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
+ <sonar.sources>.</sonar.sources>
+ <sonar.junit.reportsPath>xunit-results.xml</sonar.junit.reportsPath>
+ <sonar.python.coverage.reportPath>coverage.xml</sonar.python.coverage.reportPath>
+ <sonar.language>py</sonar.language>
+ <sonar.pluginname>python</sonar.pluginname>
+ <sonar.inclusions>**/**.py</sonar.inclusions>
+ <sonar.exclusions>**/tests/**.py,**/test*.py,**/__init__.py,setup.py</sonar.exclusions>
+ </properties>
<description>vfc gvnfm vnflcm lcm</description>
<build>
+ <pluginManagement>
+ <plugins>
+ <plugin>
+ <groupId>org.codehaus.mojo</groupId>
+ <artifactId>exec-maven-plugin</artifactId>
+ <version>1.2.1</version>
+ <configuration>
+ <executable>${session.executionRootDirectory}/mvn-phase-script.sh</executable>
+ <environmentVariables>
+ <!-- make mvn properties as env for our script -->
+ <MVN_PROJECT_GROUPID>${project.groupId}</MVN_PROJECT_GROUPID>
+ <MVN_PROJECT_ARTIFACTID>${project.artifactId}</MVN_PROJECT_ARTIFACTID>
+ <MVN_PROJECT_VERSION>${project.version}</MVN_PROJECT_VERSION>
+ </environmentVariables>
+ </configuration>
+ </plugin>
+ </plugins>
+ </pluginManagement>
<plugins>
<plugin>
+ <groupId>org.codehaus.mojo</groupId>
+ <artifactId>exec-maven-plugin</artifactId>
+ <version>1.2.1</version>
+ <executions>
+ <execution>
+ <id>clean phase script</id>
+ <phase>clean</phase>
+ <goals>
+ <goal>exec</goal>
+ </goals>
+ <configuration>
+ <arguments>
+ <argument>__</argument>
+ <argument>clean</argument>
+ </arguments>
+ </configuration>
+ </execution>
+ <execution>
+ <id>test script</id>
+ <phase>test</phase>
+ <goals>
+ <goal>exec</goal>
+ </goals>
+ <configuration>
+ <arguments>
+ <argument>__</argument>
+ <argument>test</argument>
+ </arguments>
+ </configuration>
+ </execution>
+ </executions>
+ </plugin>
+ <plugin>
<artifactId>maven-assembly-plugin</artifactId>
<configuration>
<appendAssemblyId>false</appendAssemblyId>