summaryrefslogtreecommitdiffstats
path: root/pom.xml
diff options
context:
space:
mode:
authorDR695H <dr695h@att.com>2019-04-11 22:49:34 -0400
committerDR695H <dr695h@att.com>2019-04-11 23:06:24 -0400
commitef6f4c4e161bbad51a8effdef56e551970332ceb (patch)
treeca00bf6d41c00e22ac0c7094102fb7ecfb4680db /pom.xml
parentf64f67987e57e6beda2514612ab4933a4950f885 (diff)
Add templating engine
flesh out the setup.py, add in a jinja template engine Python2.7 Also enhanced gitignore and added a pom.xml to eventually start getting this into the nexus3 repo Change-Id: I0fbef46941211fdbffe183614fba0c08edc9ed31 Issue-ID: TEST-140 Signed-off-by: DR695H <dr695h@att.com>
Diffstat (limited to 'pom.xml')
-rw-r--r--pom.xml82
1 files changed, 82 insertions, 0 deletions
diff --git a/pom.xml b/pom.xml
new file mode 100644
index 0000000..b196873
--- /dev/null
+++ b/pom.xml
@@ -0,0 +1,82 @@
+<?xml version="1.0"?>
+<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+ <packaging>pom</packaging>
+ <groupId>org.onap.testsuite</groupId>
+ <artifactId>python-testing-utils</artifactId>
+ <name>testsuite-python-testing-utils</name>
+ <version>0.3.0-SNAPSHOT</version>
+ <description>Scripts written to be used during robot framework testing</description>
+ <parent>
+ <groupId>org.onap.oparent</groupId>
+ <artifactId>oparent-python</artifactId>
+ <version>1.2.3</version>
+ </parent>
+ <properties>
+ <wheel.name>${project.artifactId}-${python_version}-py2-none-any.whl</wheel.name>
+ <python.sourceDirectory>${project.basedir}</python.sourceDirectory>
+ <python.pypi.repository>https://nexus3.onap.org/repository/PyPi.snapshot/</python.pypi.repository>
+ </properties>
+ <build>
+ <plugins>
+ <plugin>
+ <groupId>org.codehaus.mojo</groupId>
+ <artifactId>build-helper-maven-plugin</artifactId>
+ <executions>
+ <execution>
+ <id>attach-artifacts</id>
+ <configuration>
+ <artifacts>
+ <artifact>
+ <file>${project.build.directory}/maven-python/dist/${wheel.name}</file>
+ <type>whl</type>
+ </artifact>
+ </artifacts>
+ <skipAttach>false</skipAttach>
+ </configuration>
+ </execution>
+ </executions>
+ </plugin>
+ <plugin>
+ <groupId>com.github.UltimateDogg</groupId>
+ <artifactId>maven-python-distribute-plugin</artifactId>
+ <executions>
+ <execution>
+ <id>package</id>
+ <goals>
+ <goal>package</goal>
+ </goals>
+ </execution>
+ <execution>
+ <id>process</id>
+ <goals>
+ <goal>process-sources</goal>
+ </goals>
+ </execution>
+ <execution>
+ <id>deploy</id>
+ <goals>
+ <goal>deploy</goal>
+ </goals>
+ </execution>
+ </executions>
+ <configuration>
+ <repository>${python.pypi.repository}</repository>
+ <sourceDirectory>${python.sourceDirectory}</sourceDirectory>
+ </configuration>
+ </plugin>
+ <plugin>
+ <artifactId>exec-maven-plugin</artifactId>
+ <groupId>org.codehaus.mojo</groupId>
+ <executions>
+ <execution>
+ <id>tox-test</id>
+ <configuration>
+ <workingDirectory>${project.build.directory}/maven-python/eteutils</workingDirectory>
+ </configuration>
+ </execution>
+ </executions>
+ </plugin>
+ </plugins>
+ </build>
+</project> \ No newline at end of file