aboutsummaryrefslogtreecommitdiffstats
path: root/mso-catalog-db/pom.xml
diff options
context:
space:
mode:
authorBenjamin, Max (mb388a) <mb388a@us.att.com>2018-07-30 15:56:09 -0400
committerBenjamin, Max (mb388a) <mb388a@us.att.com>2018-07-31 11:09:25 -0400
commit5a6a6de6f1a26a1897e4917a0df613e25a24eb70 (patch)
tree59a968f27b4b603aacc9d5e7b51fb598aeec5321 /mso-catalog-db/pom.xml
parentb6dc38501f3b746426b42d9de4cc883d894149e8 (diff)
Containerization feature of SO
Change-Id: I95381232eeefcd247a66a5cec370a8ce1c288e18 Issue-ID: SO-670 Signed-off-by: Benjamin, Max (mb388a) <mb388a@us.att.com>
Diffstat (limited to 'mso-catalog-db/pom.xml')
-rw-r--r--mso-catalog-db/pom.xml189
1 files changed, 55 insertions, 134 deletions
diff --git a/mso-catalog-db/pom.xml b/mso-catalog-db/pom.xml
index 343b67960d..7f86cbad1a 100644
--- a/mso-catalog-db/pom.xml
+++ b/mso-catalog-db/pom.xml
@@ -1,10 +1,11 @@
-<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
<modelVersion>4.0.0</modelVersion>
<parent>
<groupId>org.onap.so</groupId>
<artifactId>so</artifactId>
- <version>1.2.0-SNAPSHOT</version>
+ <version>1.3.0-SNAPSHOT</version>
</parent>
<artifactId>mso-catalog-db</artifactId>
@@ -15,160 +16,80 @@
<finalName>${project.artifactId}</finalName>
<plugins>
<plugin>
- <groupId>de.juplo</groupId>
- <artifactId>hibernate4-maven-plugin</artifactId>
- <version>1.1.0</version>
+ <groupId>org.apache.maven.plugins</groupId>
+ <artifactId>maven-jar-plugin</artifactId>
<executions>
- <!-- MySQL -->
<execution>
- <id>MySQL</id>
+ <phase>package</phase>
<goals>
- <goal>export</goal>
+ <goal>jar</goal>
</goals>
<configuration>
- <hibernateDialect>org.hibernate.dialect.MySQL5Dialect</hibernateDialect>
- <hibernateMapping>
- ${project.basedir}/src/main/resources/AllottedResource.hbm.xml,
- ${project.basedir}/src/main/resources/AllottedResourceCustomization.hbm.xml,
- ${project.basedir}/src/main/resources/HeatEnvironment.hbm.xml,
- ${project.basedir}/src/main/resources/HeatFiles.hbm.xml,
- ${project.basedir}/src/main/resources/HeatNestedTemplate.hbm.xml,
- ${project.basedir}/src/main/resources/HeatTemplate.hbm.xml,
- ${project.basedir}/src/main/resources/ModelRecipe.hbm.xml,
- ${project.basedir}/src/main/resources/NetworkRecipe.hbm.xml,
- ${project.basedir}/src/main/resources/NetworkResource.hbm.xml,
- ${project.basedir}/src/main/resources/NetworkResourceCustomization.hbm.xml,
- ${project.basedir}/src/main/resources/Service.hbm.xml,
- ${project.basedir}/src/main/resources/ServiceRecipe.hbm.xml,
- ${project.basedir}/src/main/resources/ServiceToAllottedResources.hbm.xml,
- ${project.basedir}/src/main/resources/ServiceToNetworks.hbm.xml,
- ${project.basedir}/src/main/resources/ServiceToResourceCustomization.hbm.xml,
- ${project.basedir}/src/main/resources/TempNetworkHeatTemplateLookup.hbm.xml,
- ${project.basedir}/src/main/resources/ToscaCsar.hbm.xml,
- ${project.basedir}/src/main/resources/VfModule.hbm.xml,
- ${project.basedir}/src/main/resources/VfModuleCustomization.hbm.xml,
- ${project.basedir}/src/main/resources/VfModuleToHeatFiles.hbm.xml,
- ${project.basedir}/src/main/resources/VnfComponent.hbm.xml,
- ${project.basedir}/src/main/resources/VnfComponentsRecipe.hbm.xml,
- ${project.basedir}/src/main/resources/VnfRecipe.hbm.xml,
- ${project.basedir}/src/main/resources/VnfResCustomToVfModuleCustom.hbm.xml,
- ${project.basedir}/src/main/resources/VnfResource.hbm.xml,
- ${project.basedir}/src/main/resources/VnfResourceCustomization.hbm.xml
- </hibernateMapping>
- <target>SCRIPT</target>
- <skip>false</skip>
- <force>true</force>
- <outputFile>${project.build.directory}/MySQL-Catalog-schema.sql</outputFile>
+ <classifier>beans</classifier>
+ <includes>
+ <include>**/beans/*</include>
+ <include>**/macro/*</include>
+ <include>**/utils/*</include>
+ </includes>
</configuration>
</execution>
</executions>
</plugin>
- <plugin>
- <artifactId>maven-resources-plugin</artifactId>
- <version>3.0.1</version>
- <executions>
-
- <execution>
- <id>copy-sql-file</id>
- <phase>install</phase>
- <goals>
- <goal>copy-resources</goal>
- </goals>
- <configuration>
- <overwrite>true</overwrite>
-
- <outputDirectory>${project.basedir}/../packages/root-pack-extras/config-resources/mariadb/db-sql-scripts/main-schemas</outputDirectory>
-
- <resources>
- <resource>
- <directory>${project.build.directory}</directory>
- <filtering>false</filtering>
- <includes>
- <include>*.sql</include>
- </includes>
- </resource>
- </resources>
- </configuration>
- </execution>
- </executions>
- </plugin>
</plugins>
<pluginManagement>
<plugins>
- <!--This plugin's configuration is used to store Eclipse m2e settings only. It has no influence on the Maven build itself.-->
- <plugin>
- <groupId>org.eclipse.m2e</groupId>
- <artifactId>lifecycle-mapping</artifactId>
- <version>1.0.0</version>
- <configuration>
- <lifecycleMappingMetadata>
- <pluginExecutions>
- <pluginExecution>
- <pluginExecutionFilter>
- <groupId>de.juplo</groupId>
- <artifactId>
- hibernate4-maven-plugin
- </artifactId>
- <versionRange>
- [1.0.3,)
- </versionRange>
- <goals>
- <goal>export</goal>
- </goals>
- </pluginExecutionFilter>
- <action>
- <ignore></ignore>
- </action>
- </pluginExecution>
- </pluginExecutions>
- </lifecycleMappingMetadata>
- </configuration>
- </plugin>
+
</plugins>
</pluginManagement>
</build>
-
<dependencies>
<dependency>
- <groupId>org.hibernate</groupId>
- <artifactId>hibernate-core</artifactId>
- <version>4.3.6.Final</version>
- <exclusions>
- <!-- Avoid hibernate inclusion as provided in Jboss -->
- <exclusion>
- <groupId>org.jboss</groupId>
- <artifactId>jandex</artifactId>
- </exclusion>
- <exclusion>
- <groupId>org.javassist</groupId>
- <artifactId>javassist</artifactId>
- </exclusion>
- <exclusion>
- <groupId>org.jboss.logging</groupId>
- <artifactId>jboss-logging</artifactId>
- </exclusion>
- <exclusion>
- <groupId>org.jboss.logging</groupId>
- <artifactId>jboss-logging-annotations</artifactId>
- </exclusion>
- <exclusion>
- <groupId>org.jboss.spec.javax.transaction</groupId>
- <artifactId>jboss-transaction-api_1.2_spec</artifactId>
- </exclusion>
- <exclusion>
- <groupId>antlr</groupId>
- <artifactId>antlr</artifactId>
- </exclusion>
- <exclusion>
- <groupId>dom4j</groupId>
- <artifactId>dom4j</artifactId>
- </exclusion>
- </exclusions>
+ <groupId>uk.co.blackpepper.bowman</groupId>
+ <artifactId>bowman-client</artifactId>
+ <version>0.3.0</version>
</dependency>
<dependency>
<groupId>org.onap.so</groupId>
<artifactId>common</artifactId>
<version>${project.version}</version>
</dependency>
+ <dependency>
+ <groupId>org.springframework.boot</groupId>
+ <artifactId>spring-boot-starter-data-jpa</artifactId>
+ <optional>true</optional>
+ </dependency>
+ <dependency>
+ <groupId>org.mariadb.jdbc</groupId>
+ <artifactId>mariadb-java-client</artifactId>
+ </dependency>
+ <dependency>
+ <groupId>com.openpojo</groupId>
+ <artifactId>openpojo</artifactId>
+ <version>0.8.6</version>
+ </dependency>
+ <dependency>
+ <groupId>org.springframework.boot</groupId>
+ <artifactId>spring-boot-starter-test</artifactId>
+ <scope>test</scope>
+ </dependency>
+ <dependency>
+ <groupId>ch.vorburger.mariaDB4j</groupId>
+ <artifactId>mariaDB4j</artifactId>
+ <version>2.2.3</version>
+ <scope>test</scope>
+ </dependency>
+ <dependency>
+ <groupId>org.springframework.boot</groupId>
+ <artifactId>spring-boot-starter-data-rest</artifactId>
+ </dependency>
+ <dependency>
+ <groupId>org.springframework.data</groupId>
+ <artifactId>spring-data-rest-hal-browser</artifactId>
+ </dependency>
+ <dependency>
+ <groupId>org.ow2.asm</groupId>
+ <artifactId>asm-xml</artifactId>
+ <version>6.1</version>
+ </dependency>
</dependencies>
</project>