aboutsummaryrefslogtreecommitdiffstats
path: root/aria/multivim-plugin/setup.py
diff options
context:
space:
mode:
authordfilppi <dewayne@gigaspaces.com>2017-08-07 20:10:53 +0000
committerdfilppi <dewayne@gigaspaces.com>2017-08-07 20:10:53 +0000
commit9981f55920a6f1c1f20396d42e35b075b22f6a8f (patch)
tree1199993b9bae728c5274ae3062988dc9f357eb5b /aria/multivim-plugin/setup.py
parent4538e26e2a60bd325d63c19bcc7d0fed37ccce96 (diff)
ARIA multivim plugin initial checkin
Change-Id: I3a24ab6fc5ba54466bfecaf596a13b8907248ae8 Issue-id: SO-77 Signed-off-by: DeWayne Filppi <dewayne@gigaspaces.com>
Diffstat (limited to 'aria/multivim-plugin/setup.py')
-rw-r--r--aria/multivim-plugin/setup.py45
1 files changed, 45 insertions, 0 deletions
diff --git a/aria/multivim-plugin/setup.py b/aria/multivim-plugin/setup.py
new file mode 100644
index 0000000000..116aba507c
--- /dev/null
+++ b/aria/multivim-plugin/setup.py
@@ -0,0 +1,45 @@
+#########
+# Copyright (c) 2014 GigaSpaces Technologies Ltd. All rights reserved
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# * WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# * See the License for the specific language governing permissions and
+# * limitations under the License.
+
+from setuptools import setup
+
+
+setup(
+ zip_safe=True,
+ name='cloudify-openstack-plugin',
+ version='2.2.0',
+ author='idanmo',
+ author_email='idan@gigaspaces.com',
+ packages=[
+ 'openstack_plugin_common',
+ 'nova_plugin',
+ 'neutron_plugin',
+ 'cinder_plugin',
+ 'glance_plugin',
+ 'keystone_plugin'
+ ],
+ license='LICENSE',
+ description='Cloudify plugin for OpenStack infrastructure.',
+ install_requires=[
+ 'cloudify-plugins-common>=3.3.1',
+ 'keystoneauth1>=2.16.0,<3',
+ 'python-novaclient==7.0.0',
+ 'python-keystoneclient==3.5.0',
+ 'python-neutronclient==6.0.0',
+ 'python-cinderclient==1.9.0',
+ 'python-glanceclient==2.5.0',
+ 'IPy==0.81'
+ ]
+)