aboutsummaryrefslogtreecommitdiffstats
path: root/aria/multivim-plugin/setup.py
diff options
context:
space:
mode:
authordfilppi <dewayne@cloudify.co>2017-08-31 00:15:51 +0000
committerDeWayne Filppi <dewayne@cloudify.co>2017-09-07 16:37:00 +0000
commitdf40f6f09f11aa823c1fd07e85887885f20d356b (patch)
treec5d186d21602ad4464e0b7ec6cc8618d9a7a8f54 /aria/multivim-plugin/setup.py
parentdcb890a6fa153900a0562872ccc31a5df2dffd24 (diff)
reorg and add pom build for wheel
Change-Id: Iab761e263f1e2380471dd38c2b7ce9b77f0aab0e Signed-off-by: DeWayne Filppi <dewayne@cloudify.co> Issue-id: SO-106
Diffstat (limited to 'aria/multivim-plugin/setup.py')
-rw-r--r--aria/multivim-plugin/setup.py45
1 files changed, 0 insertions, 45 deletions
diff --git a/aria/multivim-plugin/setup.py b/aria/multivim-plugin/setup.py
deleted file mode 100644
index 116aba507c..0000000000
--- a/aria/multivim-plugin/setup.py
+++ /dev/null
@@ -1,45 +0,0 @@
-#########
-# Copyright (c) 2014 GigaSpaces Technologies Ltd. All rights reserved
-#
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# * WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# * See the License for the specific language governing permissions and
-# * limitations under the License.
-
-from setuptools import setup
-
-
-setup(
- zip_safe=True,
- name='cloudify-openstack-plugin',
- version='2.2.0',
- author='idanmo',
- author_email='idan@gigaspaces.com',
- packages=[
- 'openstack_plugin_common',
- 'nova_plugin',
- 'neutron_plugin',
- 'cinder_plugin',
- 'glance_plugin',
- 'keystone_plugin'
- ],
- license='LICENSE',
- description='Cloudify plugin for OpenStack infrastructure.',
- install_requires=[
- 'cloudify-plugins-common>=3.3.1',
- 'keystoneauth1>=2.16.0,<3',
- 'python-novaclient==7.0.0',
- 'python-keystoneclient==3.5.0',
- 'python-neutronclient==6.0.0',
- 'python-cinderclient==1.9.0',
- 'python-glanceclient==2.5.0',
- 'IPy==0.81'
- ]
-)