aboutsummaryrefslogtreecommitdiffstats
path: root/aria/aria-rest-server/src/main/python/aria-rest/setup.py
diff options
context:
space:
mode:
authorSeshu Kumar M <seshu.kumar.m@huawei.com>2017-08-07 07:33:22 +0000
committerGerrit Code Review <gerrit@onap.org>2017-08-07 07:33:22 +0000
commit3d12536915834869d4b68f101cd3724a54d0dc2a (patch)
treee78adec3923925dd6cbd3e16222b8dc339eb482d /aria/aria-rest-server/src/main/python/aria-rest/setup.py
parent7821df2b0170959868c5752f66eaaca07ba469b1 (diff)
parentfd22d8ef4876ba53629b84fb84d46724273d6107 (diff)
Merge "ARIA REST server initial commit"
Diffstat (limited to 'aria/aria-rest-server/src/main/python/aria-rest/setup.py')
-rw-r--r--aria/aria-rest-server/src/main/python/aria-rest/setup.py41
1 files changed, 41 insertions, 0 deletions
diff --git a/aria/aria-rest-server/src/main/python/aria-rest/setup.py b/aria/aria-rest-server/src/main/python/aria-rest/setup.py
new file mode 100644
index 0000000000..8c80a9004d
--- /dev/null
+++ b/aria/aria-rest-server/src/main/python/aria-rest/setup.py
@@ -0,0 +1,41 @@
+#
+# ============LICENSE_START===================================================
+# Copyright (c) 2017 Cloudify.co. All rights reserved.
+# ===================================================================
+# Licensed under the Apache License, Version 2.0 (the "License"); you may not
+# use this file except in compliance with the License. You may obtain a copy
+# of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS, WITHOUT
+# WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the
+# License for the specific language governing permissions and limitations under
+# the License.
+# ============LICENSE_END====================================================
+#
+
+
+from setuptools import setup
+
+setup(
+ zip_safe=True,
+ name='aria-rest',
+ version='0.1',
+ author='dewayne',
+ author_email='dewayne@gigaspaces.com',
+ packages=[
+ 'aria_rest'
+ ],
+ entry_points = {
+ 'console_scripts' : ['aria-rest=aria_rest.rest:main']
+ },
+ license='LICENSE',
+ description='Aria REST API for ONAP',
+ install_requires=[
+ 'Flask==0.12.2',
+ 'flask-autodoc==0.1.2',
+ 'apache-ariatosca==0.1.0'
+ ]
+)