aboutsummaryrefslogtreecommitdiffstats
path: root/pom.xml
diff options
context:
space:
mode:
Diffstat (limited to 'pom.xml')
-rw-r--r--pom.xml11
1 files changed, 11 insertions, 0 deletions
diff --git a/pom.xml b/pom.xml
index b186789..368de37 100644
--- a/pom.xml
+++ b/pom.xml
@@ -18,6 +18,7 @@
<sonar.tests>lib</sonar.tests>
<sonar.test.inclusions>lib/*.spec.ts</sonar.test.inclusions>
<sonar.typescript.lcov.reportPaths>coverage/lcov.info</sonar.typescript.lcov.reportPaths>
+ <sonar.typescript.tslint.reportPaths>coverage/tslint-report.json</sonar.typescript.tslint.reportPaths>
<sonar.testExecutionReportPaths>coverage/test-report.xml</sonar.testExecutionReportPaths>
</properties>
@@ -113,6 +114,16 @@
</execution>
<execution>
+ <id>npm tslint</id>
+ <goals>
+ <goal>npm</goal>
+ </goals>
+ <configuration>
+ <arguments>run lint</arguments>
+ </configuration>
+ </execution>
+
+ <execution>
<id>npm run build</id>
<goals>
<goal>npm</goal>