summaryrefslogtreecommitdiffstats
path: root/catalog-be/pom.xml
diff options
context:
space:
mode:
authork.kedron <k.kedron@partner.samsung.com>2020-03-05 13:12:27 +0100
committerOfir Sonsino <ofir.sonsino@intl.att.com>2020-06-24 06:01:11 +0000
commitcb30f3a566b73c78c3ea666acfcd3f288098684a (patch)
tree38cd1acb83ddde2b927485611d130bbeec3c1a4b /catalog-be/pom.xml
parentbdbfc2e460ccb561c3e174260b2908b974996d4f (diff)
Refactoring the sdc-BE-init python scripts
Deeper refactoring of python script: - create the python package with init script - support for python 3.x - reuse code - new design - support for .json conf file - update the docker chef script Issue-ID: SDC-2784 Signed-off-by: Krystian Kedron <k.kedron@partner.samsung.com> Change-Id: I02169eb7d0e3e90851ba1811536d1712c3b4145f
Diffstat (limited to 'catalog-be/pom.xml')
-rw-r--r--catalog-be/pom.xml21
1 files changed, 21 insertions, 0 deletions
diff --git a/catalog-be/pom.xml b/catalog-be/pom.xml
index d0a0f95f8a..cbaf2094a3 100644
--- a/catalog-be/pom.xml
+++ b/catalog-be/pom.xml
@@ -1165,6 +1165,27 @@
</resources>
</configuration>
</execution>
+ <execution>
+ <id>copy-sdc-be-py</id>
+ <phase>verify</phase>
+ <goals>
+ <goal>copy-resources</goal>
+ </goals>
+ <configuration>
+ <outputDirectory>
+ sdc-backend-init/
+ </outputDirectory>
+ <resources>
+ <resource>
+ <directory>${project.parent.basedir}/catalog-be/src/main/resources/</directory>
+ <includes>
+ <include>scripts/sdcBePy/**</include>
+ <inculde>scripts/setup.py</inculde>
+ </includes>
+ </resource>
+ </resources>
+ </configuration>
+ </execution>
</executions>
</plugin>
<plugin>