summaryrefslogtreecommitdiffstats
path: root/ecomp-sdk/epsdk-app-os/pom.xml
diff options
context:
space:
mode:
authorRupinder <rupinsi1@in.ibm.com>2020-03-11 20:29:15 +0530
committerRupinderjeet Singh <rupinsi1@in.ibm.com>2020-03-12 09:00:13 +0000
commit5faf4d3c3c28456e7db129fe8cfbbbf69b1ac9c2 (patch)
tree956c4eb86c9f19e91a66837772bd5905277fb7f6 /ecomp-sdk/epsdk-app-os/pom.xml
parent1dc25cca722492de0d28487ddf24936e2bf875a5 (diff)
made change in pom.xml and other files
Made changes in pom.xml to enable the sonar coverage Issue-ID: PORTAL-834 Change-Id: I61590ab93ad67883ac2a4fca3f50b27e387f8c71 Signed-off-by: Rupinder<rupinsi1@in.ibm.com>
Diffstat (limited to 'ecomp-sdk/epsdk-app-os/pom.xml')
-rw-r--r--ecomp-sdk/epsdk-app-os/pom.xml13
1 files changed, 13 insertions, 0 deletions
diff --git a/ecomp-sdk/epsdk-app-os/pom.xml b/ecomp-sdk/epsdk-app-os/pom.xml
index 7287fe1a..add3c1a0 100644
--- a/ecomp-sdk/epsdk-app-os/pom.xml
+++ b/ecomp-sdk/epsdk-app-os/pom.xml
@@ -30,6 +30,16 @@
<!-- Version number gets stored only here -->
<tomcat.download.path>http://archive.apache.org/dist/tomcat/tomcat-8/v8.0.37/bin</tomcat.download.path>
<tomcat.download.name>apache-tomcat-8.0.37</tomcat.download.name>
+
+ <sonar.typescript.lcov.reportPaths>ngapp/coverage/lcov.info</sonar.typescript.lcov.reportPaths>
+ <sonar.sources>ngapp/src</sonar.sources>
+ <sonar.projectKey>portal-sdk</sonar.projectKey>
+ <sonar.projectName>portal-sdk</sonar.projectName>
+ <sonar.exclusions>**/node_modules/**,**/*.spec.ts</sonar.exclusions>
+ <sonar.test.inclusions>**/*.spec.ts</sonar.test.inclusions>
+ <sonar.tests>ngapp/src</sonar.tests>
+ <sonar.sourceEncoding>UTF-8</sonar.sourceEncoding>
+
</properties>
<!-- repositories are inherited from parent -->
@@ -130,6 +140,7 @@
<outputDirectory>${project.basedir}/target/site/jacoco</outputDirectory>
</configuration>
</execution>
+
</executions>
</plugin>
@@ -160,7 +171,9 @@
</goals>
</execution>
+
<execution>
+
<id>npm run build</id>
<phase>compile</phase>
<goals>