aboutsummaryrefslogtreecommitdiffstats
path: root/controlloop/common
AgeCommit message (Collapse)AuthorFilesLines
2020-09-02Add guard filter properties to controllerPamela Dragosh4-7/+212
Adding new properties to guard Decision call. Issue-ID: POLICY-2590 Change-Id: Ie4a37990e062c76ac4d6dd1b904ad354736fd27a Signed-off-by: Pamela Dragosh <pdragosh@research.att.com> Signed-off-by: Jim Hahn <jrh3@att.com> Signed-off-by: Pamela Dragosh <pdragosh@research.att.com>
2020-09-02update the toscapolicy in ruletest setTaka Cho2-2/+2
modelVersion has to be a string instead an integer Issue-ID: POLICY-2814 Change-Id: I31c89d69f96076d490c665f4912d25e3892d011a Signed-off-by: Taka Cho <takamune.cho@att.com>
2020-09-02Merge "Allow guards to be dynamically enabled/disabled"Ram Krishna Verma3-4/+45
2020-08-31Allow guards to be dynamically enabled/disabledJim Hahn3-4/+45
Modified drools-apps so that guards can be dynamically enabled and disabled. Due to the current design, there are two properties that control this: - an actor-level property: when enabled, the DB connection is created, otherwise a stub connection is created. This property is NOT dynamic - an engine-level property: when enabled, the connection created by the actor is used, otherwise a stub connection is used. This property IS dynamic Issue-ID: POLICY-2748 Change-Id: I2a5baf908ce274f2eb46a6a3f01df1b3532038ff Signed-off-by: Jim Hahn <jrh3@att.com>
2020-08-31Merge "Add tdjam-controller"Jim Hahn28-51/+3384
2020-08-28Add tdjam-controllerStraubs, Ralph (rs8887)28-51/+3384
the details is on wiki: https://wiki.onap.org/display/DW/tdjam+Feature+for+Tosca-Driven+Control+Loops Fixed some eclipse warnings. Revised the interaction between a manager and its SerialWorkQueue to address some threading issues. The original code started processing the event as soon as the manager was created, WHILE it was still being added to the map. During junit tests, the event responses came back, within the same thread, which then attempted to remove the manager from the map. This resulted in a ConcurrentHashMap exception. Issue-ID: POLICY-2415 Change-Id: I94a4152637be76e5b2aea2d869afd84dfb413a0e Signed-off-by: Straubs, Ralph (rs8887) <rs8887@att.com> Signed-off-by: jhh <jorge.hernandez-herrero@att.com> Signed-off-by: Taka Cho <takamune.cho@att.com> Signed-off-by: Jim Hahn <jrh3@att.com>
2020-08-28Tweaks to drools-apps for new usecases controllerJim Hahn4-5/+5
Made the following updates: - modified feature-controlloop-utils to pull from the usecases controller instead of the frankfurt controller - modified ONAPInstance in the xacml-pdp Decision request - log Step2 property changes as info() instead of error() - log Lock acquisition as info() instead of warn() Issue-ID: POLICY-2748 Change-Id: I6b4b5877bbd6731acb761d09d0f0dec85561b163 Signed-off-by: Jim Hahn <jrh3@att.com>
2020-08-28Remove legacy policy from rulesJim Hahn1-25/+24
Issue-ID: POLICY-2428 Change-Id: I87b66758c8984febcd5fb6e724fac3493f5d4cdf Signed-off-by: Jim Hahn <jrh3@att.com>
2020-08-28Merge "Use ToscaPolicy instead of legacy Policy"Pamela Dragosh29-601/+444
2020-08-27Use ToscaPolicy instead of legacy PolicyJim Hahn29-601/+444
Removed usage of policy-yaml and old targetType definition. Switched to using TOSCA operational policy classes and new definitions for Target type enum. Issue-ID: POLICY-2428 Change-Id: I25d1c5219764df27bdae7f2cbeb7ada7bcef4e1e Signed-off-by: Jim Hahn <jrh3@att.com> Signed-off-by: Pamela Dragosh <pdragosh@research.att.com>
2020-08-26Move java code to rulesJim Hahn15-2/+1636
Added new usecases rules and feature. Updates per review comments: - kmodule.xml(s) Issue-ID: POLICY-2748 Change-Id: I2f5cb05a4269f98a3b0a778730434955f0919b4a Signed-off-by: Jim Hahn <jrh3@att.com>
2020-08-25Add Usecases-specific event managerJim Hahn4-5/+1840
Created new "usecases" event manager. Also fixed a couple of sonar issues in the new code. Issue-ID: POLICY-2748 Change-Id: I17a2c41bbf4f4e8158adbd8aa5e32ef570daa9d3 Signed-off-by: Jim Hahn <jrh3@att.com>
2020-08-24Add Step classes for usecases controllerJim Hahn14-0/+2235
Add usecases-specific classes for managing preprocessor steps. Issue-ID: POLICY-2748 Change-Id: I62a2bf8fbeb656a5017531a3f3de6a6dbad5a004 Signed-off-by: Jim Hahn <jrh3@att.com>
2020-08-24Merge "Add "special" Operation classes for new usecases"Pamela Dragosh13-9/+1253
2020-08-21remove legacy operational policies supportjhh7-57/+11
Issue-ID: POLICY-2765 Signed-off-by: jhh <jorge.hernandez-herrero@att.com> Change-Id: I454365943465863b108ba8668b2bc4b201986959
2020-08-21Add "special" Operation classes for new usecasesJim Hahn13-9/+1253
Created place-holder for new "usecases" controller. Note: as of yet, this is still just a normal java project; it will be turned into a full-fledged kie-based controller in a later review. Added some Operation and a few other support classes that will be needed. Note: the detmTarget() method and it's various supporting methods, detmXxx(), found in GetTargetEntityOperation2 were cloned from the pre-existing ControlLoopOperationManager2 class, and modified to fit the strategy of the new controller. Likewise for the junit tests of those methods. Issue-ID: POLICY-2748 Change-Id: Idffa135a11a56bd6afdd2728706fd40168e80912 Signed-off-by: Jim Hahn <jrh3@att.com>
2020-08-20Add generic eventmanager classesJim Hahn6-0/+1331
Added classes that are event-agnostic and support moving control from java into rules. Updates per review comments: - removed policy scope Issue-ID: POLICY-2748-event-mgr Change-Id: Icf811cc25a3975543fc5c725766b7b9df2bb87b0 Signed-off-by: Jim Hahn <jrh3@att.com>
2020-08-14Remove legacy operational policy from drools-appsJim Hahn9-136/+4
Issue-ID: POLICY-2766 Change-Id: I1ff7bbc4e301cfe6fa746f38c839acf83f7584b6 Signed-off-by: Jim Hahn <jrh3@att.com>
2020-08-11Refactor BaseRuleTest for Drools appsTaka Cho6-140/+500
1, rename BaseRuleTest to BaseTest. 2, remove drools related code in BaseTest that would use for tdjam controller. 3, DroolsRuleTest extends BaseTest that would use for frankfurt controller for drools base. Issue-ID: POLICY-2750 Change-Id: Ica9637a850de6e929f09532f077ae3e997aa2045 Signed-off-by: Taka Cho <takamune.cho@att.com>
2020-07-20Support vDNS RainyDay test Case.uj426b3-0/+105
Change-Id: I6d2b17c5379b19b04589da4d7bc4a7f6ebc4d23a Issue-ID: POLICY-2432 Signed-off-by: uj426b <uj426b@att.com>
2020-07-16Fix drools-apps CSITJim Hahn1-0/+5
Saw this in the log: java.lang.NoClassDefFoundError: org/onap/policy/models/decisions/concepts/DecisionRequest Added decisions jar to the (hopefully correct) pom. Issue-ID: POLICY-2558 Change-Id: I5a2796b3eda6b3b39b2844cd112f5a18acfa0cf8 Signed-off-by: Jim Hahn <jrh3@att.com>
2020-07-15Merge "Update-config simulator prop. with mvn assembly."Jorge Hernandez2-80/+63
2020-07-14Update-config simulator prop. with mvn assembly.uj426b2-80/+63
Change-Id: Ia91fad549dfba0b3caa623be18652b93d0bc7fce Issue-ID: POLICY-2716 Signed-off-by: uj426b <uj426b@att.com>
2020-07-14Remove usecases and legacy actor codeJim Hahn57-9380/+15
Made the following changes to remove usescase and legacy actor code: - deleted the usecases controller and feature - deleted code associated with legacy actors, with the exception of AaiManager, which is needed by RestControlLoopManager - moved the contents of the "guard" project into the m2/guard project, as that is the only thing that still needs it - modified the m2/GuardContext to get the name of its persistence unit from the properties so it could be overridden by junit tests - used eclipselink constants Also fixed a bug in the properties for the VFC actor. Addressed review comment: - removed usecases from Dockerfile Issue-ID: POLICY-2558 Change-Id: I677d68c9efed9247c3d55773abdcc736b577a6b4 Signed-off-by: Jim Hahn <jrh3@att.com>
2020-07-10Bump drools-apps to 1.7.1-SNAPSHOTJim Hahn12-12/+12
Issue-ID: POLICY-2695 Change-Id: Iec9af37a01ba35c5b5419399cfb3d3bc80093101 Signed-off-by: Jim Hahn <jrh3@att.com>
2020-07-09FIX context URI and https to false.uj426b1-1/+3
Change-Id: Iffecc4655d22b507188ea266e82046f2a82751e8 Issue-ID: POLICY-2703 Signed-off-by: uj426b <uj426b@att.com>
2020-07-06fix complete the assertionTaka Cho2-9/+19
add isInstanceOf for assertThatThrownBy. Issue-ID: POLICY-2616 Change-Id: If49255aec6004870d7d2acfeabe258def872c1fa Signed-off-by: Taka Cho <takamune.cho@att.com>
2020-07-02Use new Actor names in drools-appsJim Hahn5-33/+33
Modified drools-apps to use XxxActor instead of XxxActorServiceProvider. This is the second step of the rename. Issue-ID: POLICY-2684 Change-Id: Iea60e92f914b7719ac765b086650479be9192d98 Signed-off-by: Jim Hahn <jrh3@att.com>
2020-07-01Updating drools applications dependenciesRossC1-2/+3
Issue-ID: POLICY-2387 Change-Id: I1c3ee615f0a72a9e7cec8ccc573e27a0cbe3f02c Signed-off-by: RossC <ross.carter@est.tech>
2020-06-29Fix build breakage in drools-apps due to pairJim Hahn3-29/+30
The Pair changes made in drools-pdp also broke drools-apps builds. Replaced usage of drools.utils.Pair with apache Pair. Issue-ID: POLICY-2202 Change-Id: I50aaad47c243637688602ae6cb680a929fe3edd9 Signed-off-by: Jim Hahn <jrh3@att.com>
2020-06-26Fix build error from Pair changesJim Hahn1-4/+4
This is a quick fix to get around a build error in drools-applications due to "Pair" changes made in policy-common and/or policy-models. Issue-ID: POLICY-2202 Change-Id: If1cb60947e55d97ef7cfb1d05d69e07c54c71a05 Signed-off-by: Jim Hahn <jrh3@att.com>
2020-06-25Use parent snapshot in drools-appsJim Hahn3-8/+1
Fixed checkstyle issues that were subsequently reported. Also fixed a few eclipse warnings. Also fixed some of the sonar issues in the files that were touched: - use "{}" in logger calls - camelcase method names - use "<?>" instead of generics - add serialization ID Issue-ID: POLICY-2188 Change-Id: I5c94a2e26dd74a61a0a919e1c3da17ab02a5bc9d Signed-off-by: Jim Hahn <jrh3@att.com>
2020-06-19Changes for checkstyle 8.32Jim Hahn11-14/+6
Issue-ID: POLICY-2188 Change-Id: Ib90222c537c5440e0de52fa0acbaa99bbcc4772a Signed-off-by: Jim Hahn <jrh3@att.com>
2020-06-16Merge "change audit and metric formats in feature-controlloop-trans"Jorge Hernandez2-6/+37
2020-06-15change audit and metric formats in feature-controlloop-transJoseph Chou2-6/+37
logging enhancement Issue-ID: POLICY-2579 Change-Id: Id1e0230d3cd2ac6d921be86f127f3721c65f3e52 Signed-off-by: Joseph Chou <jc2555@att.com>
2020-06-15Remove deprecated actor propertiesJim Hahn2-18/+0
Now that the actor change has been merged, the deprecated properties can be removed from drools-apps. Done. Issue-ID: POLICY-2632 Change-Id: If4dafc489c32da4dfccd6ebac97e8e7beac2454d Signed-off-by: Jim Hahn <jrh3@att.com>
2020-06-15Merge "Adjust properties in anticipation of actor changes"Ram Krishna Verma2-10/+28
2020-06-12Adjust properties in anticipation of actor changesJim Hahn2-10/+28
Issue-ID: POLICY-2632 Change-Id: I4d20fe6b46432298ba796fe978796d5d74e1eb14 Signed-off-by: Jim Hahn <jrh3@att.com>
2020-06-12Clean up to remove controlloop.simulator.envuj426b1-42/+0
Change-Id: Ic336eb24f1f3ecda359f07714e59f075596cc105 Issue-ID: POLICY-2555 Signed-off-by: uj426b <uj426b@att.com>
2020-06-12Merge "Remove deprecated properties for CDS and VFC"Liam Fallon4-36/+6
2020-06-12Merge "sonar issue drools applications - 3"Pamela Dragosh1-1/+1
2020-06-11Remove deprecated properties for CDS and VFCJim Hahn4-36/+6
Now that the changes to the Actors have been merged, the former properties can be removed, too. Also fixed guard operator/operation name since it changed from "Guard" to "Decision". Issue-ID: POLICY-2629 Change-Id: I1c8d4575be598a8cab12b1aa4ad9b1d3e1f12113 Signed-off-by: Jim Hahn <jrh3@att.com>
2020-06-11Merge "Match property changes to CDS and VFC actors"Ram Krishna Verma2-0/+30
2020-06-10Merge "sonar issue drools-application - 2"Ram Krishna Verma1-5/+0
2020-06-10Merge "reduce sonar issue - drool-applications"Ram Krishna Verma2-17/+17
2020-06-10Match property changes to CDS and VFC actorsJim Hahn2-0/+30
An "operations" level is being added to the properties for the CDS and VFC actor. Added the new properties; the old ones can be deleted once the change to the actors has been merged. Issue-ID: POLICY-2629 Change-Id: Ib0bb3f62d6a2d3380aa6ec5a6e8b61ddd0a44c00 Signed-off-by: Jim Hahn <jrh3@att.com>
2020-06-10sonar issue drools applications - 3Taka Cho1-1/+1
get already returns string redudant return block unused import swap expected argument use equals method instead useless assignment for payload Issue-ID: POLICY-2616 Change-Id: Ie4f07085994420b7ea3f39db89f980f6594f01b7 Signed-off-by: Taka Cho <takamune.cho@att.com>
2020-06-09sonar issue drools-application - 2Taka Cho1-5/+0
fixed some sonar issues: removed empty method, put expected value in the 1st argument Change-Id: I86747938187abda34e9ab41b735d55fbf920ecd8 Issue-ID: POLICY-2616 Signed-off-by: Taka Cho <takamune.cho@att.com>
2020-06-09Merge "Fix VFC actor properties"Jorge Hernandez2-6/+12
2020-06-09Merge "Changes for feature-controlloop-util actor conf."Ram Krishna Verma2-0/+86