aboutsummaryrefslogtreecommitdiffstats
path: root/pom.xml
diff options
context:
space:
mode:
Diffstat (limited to 'pom.xml')
-rw-r--r--pom.xml31
1 files changed, 24 insertions, 7 deletions
diff --git a/pom.xml b/pom.xml
index 192d35bd2..2f1a7d248 100644
--- a/pom.xml
+++ b/pom.xml
@@ -251,7 +251,7 @@
<dependency>
<groupId>org.apache.commons</groupId>
<artifactId>commons-vfs2</artifactId>
- <version>2.0</version>
+ <version>2.2</version>
</dependency>
<dependency>
<groupId>joda-time</groupId>
@@ -293,11 +293,6 @@
<artifactId>hibernate-annotations</artifactId>
<version>3.5.6-Final</version>
</dependency>
- <!-- <dependency> -->
- <!-- <groupId>org.apache.geronimo.specs</groupId> -->
- <!-- <artifactId>geronimo-jpa_2.0_spec</artifactId> -->
- <!-- <version>1.1</version> -->
- <!-- </dependency> -->
<dependency>
<groupId>dom4j</groupId>
<artifactId>dom4j</artifactId>
@@ -464,12 +459,34 @@
<artifactId>jsf-impl</artifactId>
<version>2.1.7</version>
</dependency>
+ <!-- Other dependencies to fix nexus IQ reported vulnerabilities -->
+ <dependency>
+ <groupId>org.codehaus.plexus</groupId>
+ <artifactId>plexus-utils</artifactId>
+ <version>3.0.24</version>
+ </dependency>
+ <dependency>
+ <groupId>commons-fileupload</groupId>
+ <artifactId>commons-fileupload</artifactId>
+ <version>1.3.3</version>
+ </dependency>
+ <dependency>
+ <groupId>org.jboss.spec.javax.ws.rs</groupId>
+ <artifactId>jboss-jaxrs-api_2.0_spec</artifactId>
+ <version>1.0.1.Final</version>
+ </dependency>
<!-- Remove the MYSQL connector and replace it by Mariadb -->
<dependency>
<groupId>org.mariadb.jdbc</groupId>
<artifactId>mariadb-java-client</artifactId>
<version>2.2.1</version>
</dependency>
+ <!-- For SDC Controller -->
+ <dependency>
+ <groupId>org.openecomp.sdc.sdc-distribution-client</groupId>
+ <artifactId>sdc-distribution-client</artifactId>
+ <version>1.2.3</version>
+ </dependency>
</dependencies>
<build>
@@ -775,7 +792,7 @@
</run>
</image>
<image>
- <name>python:2</name>
+ <name>python:2-slim</name>
<alias>python</alias>
<run>
<hostname>python</hostname>