summaryrefslogtreecommitdiffstats
path: root/pom.xml
diff options
context:
space:
mode:
authorDileep Ranganathan <dileep.ranganathan@intel.com>2018-03-01 06:20:22 -0800
committerDileep Ranganathan <dileep.ranganathan@intel.com>2018-03-01 10:41:33 -0800
commit413abf436d94d48019f3995a860e0d43ea291b96 (patch)
tree110174c44cfbae956c3380735c7001fe215f045c /pom.xml
parent69dda22c24d32535c96030a1b74c04cb64963b93 (diff)
Integrate optf/has with Sonar
Added sonar properties for python related config Added custom inclusion/exclusion patterns which could be leveraged Change-Id: I3992a9120a30555fc933c1b052984367af69e4da Issue-ID: OPTFRA-101 Signed-off-by: Dileep Ranganathan <dileep.ranganathan@intel.com>
Diffstat (limited to 'pom.xml')
-rw-r--r--pom.xml15
1 files changed, 14 insertions, 1 deletions
diff --git a/pom.xml b/pom.xml
index 37a62d3..505fac8 100644
--- a/pom.xml
+++ b/pom.xml
@@ -26,7 +26,7 @@
</parent>
<groupId>org.onap.optf.has</groupId>
- <artifactId>optf-has-root</artifactId>
+ <artifactId>optf-has</artifactId>
<name>optf-has</name>
<version>1.1.0-SNAPSHOT</version>
@@ -37,6 +37,19 @@
<!--<module>docs</module>-->
</modules>
+ <properties>
+ <sonar.sourceEncoding>UTF-8</sonar.sourceEncoding>
+ <sonar.sources>conductor/conductor</sonar.sources>
+ <sonar.tests>conductor/conductor/tests</sonar.tests>
+ <sonar.python.coverage.reportPath>conductor/cover/coverage.xml</sonar.python.coverage.reportPath>
+ <sonar.language>py</sonar.language>
+ <sonar.pluginname>python</sonar.pluginname>
+ <sonar.inclusions>**/**.py</sonar.inclusions>
+ <sonar.exclusions>**/tests/**,setup.py,**/lib/**</sonar.exclusions>
+ <sonar.test.inclusions>**/tests/**.py</sonar.test.inclusions>
+ <sonar.test.exclusions>**/**.py,setup.py,**/lib/**</sonar.test.exclusions>
+ </properties>
+
<build>
<plugins>
<plugin>