summaryrefslogtreecommitdiffstats
path: root/pom.xml
diff options
context:
space:
mode:
authorvrvarma <vikas.varma@att.com>2020-03-17 10:58:26 -0400
committervrvarma <vikas.varma@att.com>2020-03-17 10:58:54 -0400
commit0e4e5fcf2bb2784ba748bede15be644af0537c8d (patch)
tree011fa5a8c77557ae8894554f5ffddb126b5fecd8 /pom.xml
parentf71964798d461c4378e74c2f4d4ca8e865673b4a (diff)
Build changes to generate docker staging images for optf-has
Change-Id: I4e9fa87c7b7aed47d73c9a2f39f2f893a57a731a Signed-off-by: vrvarma <vikas.varma@att.com> Issue-ID: OPTFRA-718
Diffstat (limited to 'pom.xml')
-rw-r--r--pom.xml5
1 files changed, 5 insertions, 0 deletions
diff --git a/pom.xml b/pom.xml
index bf7bbf7..14f5ec9 100644
--- a/pom.xml
+++ b/pom.xml
@@ -48,6 +48,11 @@
<sonar.exclusions>**/tests/**,setup.py,**/lib/**</sonar.exclusions>
<sonar.test.inclusions>**/tests/**.py</sonar.test.inclusions>
<sonar.test.exclusions>**/**.py,setup.py,**/lib/**</sonar.test.exclusions>
+ <maven.build.timestamp.format>yyyyMMdd'T'HHmmss'Z'</maven.build.timestamp.format>
+ <has.build.timestamp>${maven.build.timestamp}</has.build.timestamp>
+ <has.project.version>${project.version}</has.project.version>
+ <has.docker.repository>nexus3.onap.org:10003</has.docker.repository>
+ <image.namespace>${has.docker.repository}/onap/optf-has</image.namespace>
</properties>
<build>