summaryrefslogtreecommitdiffstats
path: root/conductor/setup.py
diff options
context:
space:
mode:
authorrl001m <ruilu@research.att.com>2017-12-17 09:04:31 -0500
committerrl001m <ruilu@research.att.com>2017-12-17 09:05:11 -0500
commit710d958a29198b6633236c1b7cad12babfe46833 (patch)
tree5819d23e6a3b9d4e111b3debaf41ee7fe7731a78 /conductor/setup.py
parent22cff5d3b51d9aa2d4fd11f657264e41063add1c (diff)
Added all common modules in conductor directory
Added the common modules used by all the other components of Homing Optimizer. Change-Id: I6e8a991b54ef422da66b3174f27f6998731ec188 Issue-ID: OPTFRA-11 Signed-off-by: rl001m <ruilu@research.att.com>
Diffstat (limited to 'conductor/setup.py')
-rw-r--r--conductor/setup.py34
1 files changed, 34 insertions, 0 deletions
diff --git a/conductor/setup.py b/conductor/setup.py
new file mode 100644
index 0000000..0c696ed
--- /dev/null
+++ b/conductor/setup.py
@@ -0,0 +1,34 @@
+# -*- encoding: utf-8 -*-
+# -------------------------------------------------------------------------
+# Copyright (c) 2015-2017 AT&T Intellectual Property
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+# -------------------------------------------------------------------------
+#
+
+'''Setup'''
+
+import setuptools
+
+# In python < 2.7.4, a lazy loading of package `pbr` will break
+# setuptools if some other modules registered functions in `atexit`.
+# solution from: http://bugs.python.org/issue15881#msg170215
+try:
+ import multiprocessing # noqa # pylint: disable=W0611,C0411
+except ImportError:
+ pass
+
+setuptools.setup(
+ setup_requires=['pbr>=1.8'],
+ pbr=True)