summaryrefslogtreecommitdiffstats
path: root/vio/pom.xml
diff options
context:
space:
mode:
Diffstat (limited to 'vio/pom.xml')
-rw-r--r--vio/pom.xml60
1 files changed, 35 insertions, 25 deletions
diff --git a/vio/pom.xml b/vio/pom.xml
index ce9f502..210875f 100644
--- a/vio/pom.xml
+++ b/vio/pom.xml
@@ -12,7 +12,8 @@
distributed under the License is distributed on an "AS IS" BASIS,
WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-->
-<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
<parent>
<groupId>org.onap.oparent</groupId>
<artifactId>oparent</artifactId>
@@ -30,28 +31,37 @@
<project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
<project.reporting.outputEncoding>UTF-8</project.reporting.outputEncoding>
<nexusproxy>https://nexus.onap.org</nexusproxy>
+
+ <sonar.sourceEncoding>UTF-8</sonar.sourceEncoding>
+ <sonar.sources>.</sonar.sources>
+ <sonar.junit.reportsPath>xunit-results.xml</sonar.junit.reportsPath>
+ <sonar.python.coverage.reportPath>vio/coverage.xml</sonar.python.coverage.reportPath>
+ <sonar.language>py</sonar.language>
+ <sonar.pluginName>Python</sonar.pluginName>
+ <sonar.inclusions>**/*.py</sonar.inclusions>
+ <sonar.exclusions>**/tests/*,setup.py</sonar.exclusions>
</properties>
<build>
- <plugins>
- <plugin>
- <artifactId>maven-assembly-plugin</artifactId>
- <configuration>
- <appendAssemblyId>false</appendAssemblyId>
- <descriptors>
- <descriptor>assembly.xml</descriptor>
- </descriptors>
- </configuration>
- <executions>
- <execution>
- <id>make-assembly</id>
- <phase>package</phase>
- <goals>
- <goal>single</goal>
- </goals>
- </execution>
- </executions>
- </plugin>
- </plugins>
+ <plugins>
+ <plugin>
+ <artifactId>maven-assembly-plugin</artifactId>
+ <configuration>
+ <appendAssemblyId>false</appendAssemblyId>
+ <descriptors>
+ <descriptor>assembly.xml</descriptor>
+ </descriptors>
+ </configuration>
+ <executions>
+ <execution>
+ <id>make-assembly</id>
+ <phase>package</phase>
+ <goals>
+ <goal>single</goal>
+ </goals>
+ </execution>
+ </executions>
+ </plugin>
+ </plugins>
</build>
<profiles>
@@ -93,10 +103,10 @@
<configuration>
<target>
<exec executable="docker">
- <arg value="build"/>
- <arg value="-t"/>
- <arg value="${CONTAINER_PUSH_REGISTRY}/onap/multicloud/vio:${project.version}"/>
- <arg value="docker_target"/>
+ <arg value="build"/>
+ <arg value="-t"/>
+ <arg value="${CONTAINER_PUSH_REGISTRY}/onap/multicloud/vio:${project.version}"/>
+ <arg value="docker_target"/>
</exec>
<exec executable="docker">
<arg value="tag"/>