summaryrefslogtreecommitdiffstats
path: root/pom.xml
diff options
context:
space:
mode:
Diffstat (limited to 'pom.xml')
-rw-r--r--pom.xml63
1 files changed, 7 insertions, 56 deletions
diff --git a/pom.xml b/pom.xml
index 51e32db..866ab9b 100644
--- a/pom.xml
+++ b/pom.xml
@@ -27,7 +27,7 @@
<version>1.3.0-SNAPSHOT</version>
<packaging>pom</packaging>
<name>multicloud-framework</name>
- <description>multivim broker</description>
+ <description>multicloud broker</description>
<properties>
<sonar.sourceEncoding>UTF-8</sonar.sourceEncoding>
<sonar.sources>.</sonar.sources>
@@ -38,58 +38,9 @@
<sonar.inclusions>**/*.py</sonar.inclusions>
<sonar.exclusions>tests/*,setup.py</sonar.exclusions>
</properties>
- <build>
- <pluginManagement>
- <plugins>
- <plugin>
- <groupId>org.codehaus.mojo</groupId>
- <artifactId>exec-maven-plugin</artifactId>
- <version>1.1.1</version>
- <configuration>
- <executable>${session.executionRootDirectory}/sonar.sh</executable>
- <environmentVariables>
- <!-- make mvn properties as env for our script -->
- <MVN_PROJECT_GROUPID>${project.groupId}</MVN_PROJECT_GROUPID>
- <MVN_PROJECT_ARTIFACTID>${project.artifactId}</MVN_PROJECT_ARTIFACTID>
- <MVN_PROJECT_VERSION>${project.version}</MVN_PROJECT_VERSION>
- </environmentVariables>
- </configuration>
- </plugin>
- </plugins>
- </pluginManagement>
- <plugins>
- <plugin>
- <groupId>org.codehaus.mojo</groupId>
- <artifactId>exec-maven-plugin</artifactId>
- <version>1.1.1</version>
- <executions>
- <execution>
- <id>clean phase script</id>
- <phase>clean</phase>
- <goals>
- <goal>exec</goal>
- </goals>
- <configuration>
- <arguments>
- <argument>__</argument>
- <argument>clean</argument>
- </arguments>
- </configuration>
- </execution>
- <execution>
- <id>test script</id>
- <phase>test</phase>
- <goals>
- <goal>exec</goal>
- </goals>
- <configuration>
- <arguments>
- <argument>__</argument>
- <argument>test</argument>
- </arguments>
- </configuration>
- </execution>
- </executions>
- </plugin>
- </plugins>
- </build></project>
+ <modules>
+ <module>multivimbroker</module>
+ <module>artifactbroker</module>
+ </modules>
+
+</project>