diff options
author | Bin Sun <bins@vmware.com> | 2018-03-09 10:20:17 +0800 |
---|---|---|
committer | Bin Sun <bins@vmware.com> | 2018-03-09 11:13:38 +0800 |
commit | 7245fce8b57b89f1ab874ab970ae2856d0b32ef7 (patch) | |
tree | af8c76baacb3a679ab3bd6dfb114e160859253b4 /pom.xml | |
parent | c9effec3dc4eaf6c213512df96829e51996d8498 (diff) |
Fix sonar code coverage
Change-Id: Ib457043aad138746239f13f38235c2ebd4ddcb6e
Issue-ID: MULTICLOUD-172
Signed-off-by: Bin Sun <bins@vmware.com>
Diffstat (limited to 'pom.xml')
-rw-r--r-- | pom.xml | 67 |
1 files changed, 66 insertions, 1 deletions
@@ -19,6 +19,7 @@ <groupId>org.onap.oparent</groupId> <artifactId>oparent</artifactId> <version>0.1.1</version> + <relativePath>../oparent</relativePath> </parent> <modelVersion>4.0.0</modelVersion> <groupId>org.onap.multicloud.framework</groupId> @@ -27,4 +28,68 @@ <packaging>pom</packaging> <name>multicloud-framework</name> <description>multivim broker</description> -</project> + <properties> + <sonar.sourceEncoding>UTF-8</sonar.sourceEncoding> + <sonar.sources>.</sonar.sources> + <sonar.junit.reportsPath>xunit-results.xml</sonar.junit.reportsPath> + <sonar.python.coverage.reportPath>multivimbroker/coverage.xml</sonar.python.coverage.reportPath> + <sonar.language>py</sonar.language> + <sonar.pluginName>Python</sonar.pluginName> + <sonar.inclusions>**/*.py</sonar.inclusions> + <sonar.exclusions>tests/*,setup.py</sonar.exclusions> + </properties> + <build> + <pluginManagement> + <plugins> + <plugin> + <groupId>org.codehaus.mojo</groupId> + <artifactId>exec-maven-plugin</artifactId> + <version>1.1.1</version> + <configuration> + <executable>${session.executionRootDirectory}/sonar.sh</executable> + <environmentVariables> + <!-- make mvn properties as env for our script --> + <MVN_PROJECT_GROUPID>${project.groupId}</MVN_PROJECT_GROUPID> + <MVN_PROJECT_ARTIFACTID>${project.artifactId}</MVN_PROJECT_ARTIFACTID> + <MVN_PROJECT_VERSION>${project.version}</MVN_PROJECT_VERSION> + </environmentVariables> + </configuration> + </plugin> + </plugins> + </pluginManagement> + <plugins> + <plugin> + <groupId>org.codehaus.mojo</groupId> + <artifactId>exec-maven-plugin</artifactId> + <version>1.1.1</version> + <executions> + <execution> + <id>clean phase script</id> + <phase>clean</phase> + <goals> + <goal>exec</goal> + </goals> + <configuration> + <arguments> + <argument>__</argument> + <argument>clean</argument> + </arguments> + </configuration> + </execution> + <execution> + <id>test script</id> + <phase>test</phase> + <goals> + <goal>exec</goal> + </goals> + <configuration> + <arguments> + <argument>__</argument> + <argument>test</argument> + </arguments> + </configuration> + </execution> + </executions> + </plugin> + </plugins> + </build></project> |