diff options
author | liboNet <libo.zhu@intel.com> | 2019-03-20 03:10:03 +0800 |
---|---|---|
committer | liboNet <libo.zhu@intel.com> | 2019-03-20 03:17:48 +0800 |
commit | efb2229057ed70b0dd46c1e4fdfb8462727cef03 (patch) | |
tree | b83a997c45c31a6ac085bcf477ba6985fa1556fb /pom.xml | |
parent | eacb658bc442fe30d07a7971a12be917fb8cd692 (diff) |
add submodule support in framework
support multi broker and fix sonar.sh issue
. add a new module of artifact broker
. update framework pom.xml to support submodules
. update the multivim broker to align with the case
like subplugins under openstack
. remove the duplicated sonar.sh
Change-Id: Ie41dc07aed9e015208e79aadff204747269af638
Issue-ID: MULTICLOUD-532
Signed-off-by: liboNet <libo.zhu@intel.com>
Diffstat (limited to 'pom.xml')
-rw-r--r-- | pom.xml | 63 |
1 files changed, 7 insertions, 56 deletions
@@ -27,7 +27,7 @@ <version>1.3.0-SNAPSHOT</version> <packaging>pom</packaging> <name>multicloud-framework</name> - <description>multivim broker</description> + <description>multicloud broker</description> <properties> <sonar.sourceEncoding>UTF-8</sonar.sourceEncoding> <sonar.sources>.</sonar.sources> @@ -38,58 +38,9 @@ <sonar.inclusions>**/*.py</sonar.inclusions> <sonar.exclusions>tests/*,setup.py</sonar.exclusions> </properties> - <build> - <pluginManagement> - <plugins> - <plugin> - <groupId>org.codehaus.mojo</groupId> - <artifactId>exec-maven-plugin</artifactId> - <version>1.1.1</version> - <configuration> - <executable>${session.executionRootDirectory}/sonar.sh</executable> - <environmentVariables> - <!-- make mvn properties as env for our script --> - <MVN_PROJECT_GROUPID>${project.groupId}</MVN_PROJECT_GROUPID> - <MVN_PROJECT_ARTIFACTID>${project.artifactId}</MVN_PROJECT_ARTIFACTID> - <MVN_PROJECT_VERSION>${project.version}</MVN_PROJECT_VERSION> - </environmentVariables> - </configuration> - </plugin> - </plugins> - </pluginManagement> - <plugins> - <plugin> - <groupId>org.codehaus.mojo</groupId> - <artifactId>exec-maven-plugin</artifactId> - <version>1.1.1</version> - <executions> - <execution> - <id>clean phase script</id> - <phase>clean</phase> - <goals> - <goal>exec</goal> - </goals> - <configuration> - <arguments> - <argument>__</argument> - <argument>clean</argument> - </arguments> - </configuration> - </execution> - <execution> - <id>test script</id> - <phase>test</phase> - <goals> - <goal>exec</goal> - </goals> - <configuration> - <arguments> - <argument>__</argument> - <argument>test</argument> - </arguments> - </configuration> - </execution> - </executions> - </plugin> - </plugins> - </build></project> + <modules> + <module>multivimbroker</module> + <module>artifactbroker</module> + </modules> + +</project> |