summaryrefslogtreecommitdiffstats
path: root/nfvparser/src/main/python/setup.py
diff options
context:
space:
mode:
authorZhaoxing <meng.zhaoxing1@zte.com.cn>2017-07-19 07:24:51 +0800
committerZhaoxing <meng.zhaoxing1@zte.com.cn>2017-07-19 07:45:28 +0800
commitdb87c4f77a730e571338c2bf7bfcc9fdc5272185 (patch)
tree54504cabbb5d319403edc8d123e39f437d2f331a /nfvparser/src/main/python/setup.py
parent1a112663a18408161787f78f01d354a33f070957 (diff)
init nfvparser code
Change-Id: I8e264c87777e36c4a42f0aa42ab4ae66a1d59a0b Signed-off-by: Zhaoxing <meng.zhaoxing1@zte.com.cn>
Diffstat (limited to 'nfvparser/src/main/python/setup.py')
-rw-r--r--nfvparser/src/main/python/setup.py29
1 files changed, 29 insertions, 0 deletions
diff --git a/nfvparser/src/main/python/setup.py b/nfvparser/src/main/python/setup.py
new file mode 100644
index 0000000..782bb21
--- /dev/null
+++ b/nfvparser/src/main/python/setup.py
@@ -0,0 +1,29 @@
+# Copyright (c) 2013 Hewlett-Packard Development Company, L.P.
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+# implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+# THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT
+import setuptools
+
+# In python < 2.7.4, a lazy loading of package `pbr` will break
+# setuptools if some other modules registered functions in `atexit`.
+# solution from: http://bugs.python.org/issue15881#msg170215
+try:
+ import multiprocessing # noqa
+except ImportError:
+ pass
+
+setuptools.setup(
+ setup_requires=['pbr>=1.8'],
+ pbr=True)