summaryrefslogtreecommitdiffstats
path: root/config/providedConfigurations.spec
diff options
context:
space:
mode:
Diffstat (limited to 'config/providedConfigurations.spec')
-rw-r--r--config/providedConfigurations.spec25
1 files changed, 25 insertions, 0 deletions
diff --git a/config/providedConfigurations.spec b/config/providedConfigurations.spec
new file mode 100644
index 0000000..6af573f
--- /dev/null
+++ b/config/providedConfigurations.spec
@@ -0,0 +1,25 @@
+[
+ // Use https://jolt-demo.appspot.com/#inception to develop/test
+ // any changes to this file
+
+ {
+ // This section extracts configuration-id from the GENERIC-RESOURCES-API
+ // response from sdnc
+ "operation": "shift",
+ "spec": {
+ "service": {
+ "*": {
+ "service-data": {
+ "provided-configurations": {
+ "provided-configuration": {
+ "*": {
+ "configuration-id": "configuration-id[&1]"
+ }
+ }
+ }
+ }
+ }
+ }
+ }
+ }
+ ] \ No newline at end of file