summaryrefslogtreecommitdiffstats
path: root/config/sdnccontextbuilder.spec
diff options
context:
space:
mode:
authorTait,Trevor(rt0435) <rtait@amdocs.com>2018-10-26 13:27:54 -0400
committerLeigh, Phillip (pl876u) <phillip.leigh@amdocs.com>2018-10-26 15:28:46 -0400
commitf6a725a0b5b6864c09443e7f328927772a78ea05 (patch)
tree9a7aec7d4a93059e28ea1b15eee2576f1ad87c5a /config/sdnccontextbuilder.spec
parentb5f75d3996fbfd270e301abbe38766a9f6cf3a40 (diff)
SDNC context builder API Mapping Configuration
Issue-ID: LOG-421 Add code to use the VNF-API on SDNC where required. This involves using the api-mapping logic to select the VNF-API over the GNERIC-RESOURCES-API as well as adding the code to extract the information required by the VNF-API from AAI and adding the code to parse the VNF-API resonse into ModelContext. Change-Id: I4447a14d7fa39b2c5d9b655c2b20e651e56d3d77 Signed-off-by: Tait,Trevor(rt0435) <rtait@amdocs.com>
Diffstat (limited to 'config/sdnccontextbuilder.spec')
-rw-r--r--config/sdnccontextbuilder.spec76
1 files changed, 0 insertions, 76 deletions
diff --git a/config/sdnccontextbuilder.spec b/config/sdnccontextbuilder.spec
deleted file mode 100644
index 1f15b22..0000000
--- a/config/sdnccontextbuilder.spec
+++ /dev/null
@@ -1,76 +0,0 @@
-[
- // Use https://jolt-demo.appspot.com/#inception to develop/test
- // any changes to this file
-
- {
- // This section converts the updated json from service-decompostion
- // to org.onap.pomba.common.datatypes.ModelContext
- "operation": "shift",
- "spec": {
- "service": {
- "*": {
- "service-data": {
- "service-topology": {
- "service-topology-identifier": {
- "service-instance-id": "service.uuid",
- "service-instance-name": "service.name"
- },
- "onap-model-information": {
- "model-invariant-uuid": "service.invariantUUID"
- }
- },
- "vnfs": {
- "vnf": {
- "*": {
- "vnf-data": {
- "vnf-topology": {
- "onap-model-information": {
- "model-uuid": "vfList[&4].uuid",
- "model-invariant-uuid": "vfList[&4].invariantUUID"
- },
- "vnf-topology-identifier-structure": {
- "vnf-type": "vfList[&4].type",
- "vnf-name": "vfList[&4].name"
- }
- },
- "vf-modules": {
- "vf-module": {
- "*": {
- "vf-module-data": {
- "vf-module-topology": {
- "vf-module-topology-identifier": {
- "vf-module-name": "vfList[&8].vfModuleList[&4].name"
- },
- "onap-model-information": {
- "model-uuid": "vfList[&8].vfModuleList[&4].uuid",
- "model-invariant-uuid": "vfList[&8].vfModuleList[&4].invariantUUID"
- },
- "vf-module-assignments": {
- "vms": {
- "vm": {
- "*": {
- "vm-names": {
- "vm-name": {
- "@(2,vm-type)": "vfList[&13].vfModuleList[&9].vmList[&3].nfNamingCode",
- "*": "vfList[&13].vfModuleList[&9].vmList[&3].name"
- }
- }
- }
- }
- }
- }
- }
- }
- }
- }
- }
- }
- }
- }
- }
- }
- }
- }
- }
- }
- ]