summaryrefslogtreecommitdiffstats
path: root/config/networkdiscovery.spec
diff options
context:
space:
mode:
Diffstat (limited to 'config/networkdiscovery.spec')
-rw-r--r--config/networkdiscovery.spec67
1 files changed, 67 insertions, 0 deletions
diff --git a/config/networkdiscovery.spec b/config/networkdiscovery.spec
new file mode 100644
index 0000000..8da7a87
--- /dev/null
+++ b/config/networkdiscovery.spec
@@ -0,0 +1,67 @@
+[
+ // Use https://jolt-demo.appspot.com/#inception to develop/test
+ // any changes to this file
+
+ {
+ // This sections adds nfNamingCode and dataQuality to the json
+ // fields returned from service-decomposition that we are
+ // interested in
+ "operation": "default",
+ "spec": {
+ "generic-vnfs[]": {
+ "*": {
+ "vf-modules": {
+ "vf-module[]": {
+ "*": {}
+ }
+ },
+ "vservers[]": {
+ "*": {
+ "nfNamingCode": "vserver"
+ }
+ },
+ "l3-networks[]": {
+ "*": {
+ "type": "l3-network"
+ }
+ },
+ "vnfcList[]": {
+ "*": {
+ "type": "vnfc"
+ }
+ }
+ }
+ }
+ }
+ },
+ {
+ // This section converts the updated json from service-decompostion
+ // to org.onap.pomba.common.datatypes.ModelContext
+ "operation": "shift",
+ "spec": {
+ "service-instance-id": "service.uuid",
+ "generic-vnfs": {
+ "*": {
+ "vservers": {
+ "*": {
+ "vserver-id": "vfList[&3].vfModuleList[0].vmList[&1].uuid",
+ "nfNamingCode": "vfList[&3].vfModuleList[0].vmList[&1].nfNamingCode"
+ }
+ },
+ "l3-networks": {
+ "*": {
+ "network-id": "vfList[&3].vfModuleList[0].networkList[&1].uuid",
+ "type": "vfList[&3].vfModuleList[0].networkList[&1].type"
+ },
+ "vnfcs": {
+ "*": {
+ "vnfc-id": "vfList[&2].vnfcList[&1].uuid",
+ "type": "vfList[&2].vfModuleList[0].type"
+ }
+ }
+ }
+ }
+ }
+ }
+ }
+ ]