summaryrefslogtreecommitdiffstats
path: root/pylog/setup.py
diff options
context:
space:
mode:
authorAvdhut Kholkar <avdhut.kholkar@amdocs.com>2018-03-12 04:50:39 +0000
committerGerrit Code Review <gerrit@onap.org>2018-03-12 04:50:39 +0000
commita73cc9030d26f37224ca7bca72469625605d4634 (patch)
treecbf14a1e4628fcbb5d36aaa5cfd808ca1c1cf05a /pylog/setup.py
parent9ffcefcbbb6ad6b8ba485a402ccc3e469285ec4b (diff)
parent15fc9df448221c4d24fe4c097fe5e00b4512f083 (diff)
Merge " Submit python logging library seed code"
Diffstat (limited to 'pylog/setup.py')
-rw-r--r--pylog/setup.py37
1 files changed, 37 insertions, 0 deletions
diff --git a/pylog/setup.py b/pylog/setup.py
new file mode 100644
index 0000000..bcd2347
--- /dev/null
+++ b/pylog/setup.py
@@ -0,0 +1,37 @@
+# Copyright (c) 2018 VMware, Inc.
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+
+
+from setuptools import setup, find_packages
+
+setup(
+
+ name='onappylog',
+ keywords=("yaml", "logging", "mdc", "onap"),
+ description='onap python logging library',
+ long_description="python-package onappylog could be used in any python project to record MDC information and reload logging at runtime",
+ version="1.0.5",
+ license="MIT Licence",
+ author='ke liang',
+ author_email="lokyse@163.com",
+ packages=find_packages(),
+ platforms=['all'],
+ install_requires=[
+ "PyYAML>=3.10",
+ "watchdog>=0.8.3"
+ ],
+ classifiers=[
+ 'Development Status :: 4 - Beta',
+ 'Intended Audience :: Developers',
+ 'Programming Language :: Python :: 2.7'
+ ]
+)