summaryrefslogtreecommitdiffstats
path: root/onap-dcae-cbs-docker-client/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'onap-dcae-cbs-docker-client/setup.py')
-rw-r--r--onap-dcae-cbs-docker-client/setup.py27
1 files changed, 11 insertions, 16 deletions
diff --git a/onap-dcae-cbs-docker-client/setup.py b/onap-dcae-cbs-docker-client/setup.py
index 9f23048..b4fdf0e 100644
--- a/onap-dcae-cbs-docker-client/setup.py
+++ b/onap-dcae-cbs-docker-client/setup.py
@@ -1,6 +1,5 @@
-# org.onap.dcae
# ================================================================================
-# Copyright (c) 2017 AT&T Intellectual Property. All rights reserved.
+# Copyright (c) 2017-2018 AT&T Intellectual Property. All rights reserved.
# ================================================================================
# Licensed under the Apache License, Version 2.0 (the "License");
# you may not use this file except in compliance with the License.
@@ -17,23 +16,19 @@
#
# ECOMP is a trademark and service mark of AT&T Intellectual Property.
-import os
from setuptools import setup, find_packages
-from pip.req import parse_requirements
-from pip.download import PipSession
-
-install_reqs = parse_requirements("requirements.txt", session=PipSession())
-reqs = [str(ir.req) for ir in install_reqs]
setup(
- name = "onap_dcae_cbs_docker_client",
- description = "very lightweight client for a DCAE dockerized component to get it's config from the CBS",
- version = "0.0.3",
+ name="onap_dcae_cbs_docker_client",
+ description="very lightweight client for a DCAE dockerized component to get it's config from the CBS",
+ version="1.0.2",
packages=find_packages(),
- author = "Tommy Carpenter",
- author_email = "tommy@research.att.com",
+ author="Tommy Carpenter",
+ author_email="tommy@research.att.com",
license='Apache 2',
- keywords = "",
- url = "",
- install_requires=reqs
+ keywords="",
+ url="",
+ install_requires=[
+ "requests>= 2.0.0, < 3.0.0"
+ ]
)