summaryrefslogtreecommitdiffstats
path: root/onap-dcae-cbs-docker-client/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'onap-dcae-cbs-docker-client/setup.py')
-rw-r--r--onap-dcae-cbs-docker-client/setup.py39
1 files changed, 39 insertions, 0 deletions
diff --git a/onap-dcae-cbs-docker-client/setup.py b/onap-dcae-cbs-docker-client/setup.py
new file mode 100644
index 0000000..cef2525
--- /dev/null
+++ b/onap-dcae-cbs-docker-client/setup.py
@@ -0,0 +1,39 @@
+# org.onap.dcae
+# ================================================================================
+# Copyright (c) 2017 AT&T Intellectual Property. All rights reserved.
+# ================================================================================
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+# ============LICENSE_END=========================================================
+#
+# ECOMP is a trademark and service mark of AT&T Intellectual Property.
+
+import os
+from setuptools import setup, find_packages
+from pip.req import parse_requirements
+from pip.download import PipSession
+
+install_reqs = parse_requirements("requirements.txt", session=PipSession())
+reqs = [str(ir.req) for ir in install_reqs]
+
+setup(
+ name = "onap_dcae_cbs_docker_client",
+ description = "very lightweight client for a DCAE dockerized component to get it's config from the CBS",
+ version = "0.0.2",
+ packages=find_packages(),
+ author = "Tommy Carpenter",
+ author_email = "tommy at eh tee tee.com",
+ license = "",
+ keywords = "",
+ url = "",
+ install_requires=reqs
+)