summaryrefslogtreecommitdiffstats
path: root/onap-dcae-dcaepolicy-lib/setup.py
diff options
context:
space:
mode:
authorAlex Shatov <alexs@att.com>2018-03-02 13:46:11 -0500
committerAlex Shatov <alexs@att.com>2018-03-02 13:46:11 -0500
commit2b3d24bd5b513a5842adb9250b1840f9047a6d55 (patch)
tree08f2c7d39da044c257259493387ec14bfb767a81 /onap-dcae-dcaepolicy-lib/setup.py
parent1e0262d36a12343316b8a20e2541633b27372fde (diff)
2.2.0 onap-dcae-dcaepolicy-lib - refactoring
- removed the following obsolete and unused features = removed policy apply_order parsing = removed policy sorting = removed policy config merge into app-config = removed tracking fields in app-config affected by policies = removed getting config from config.content on microservice = removed org.onap.dcae from license text - simplified the logic flow without policy sorting and without getting policy configs - removed the option to pass the policy configs to plugins = only passing the policy bodies to be included into the policy-notification message - refactoring to reduce function complexity according to sonar - reduced the unit tests to match the new code - coverage is 80% Change-Id: I47729683a45a647b7510edeb85bc018fc7bb8200 Signed-off-by: Alex Shatov <alexs@att.com> Issue-ID: DCAEGEN2-347
Diffstat (limited to 'onap-dcae-dcaepolicy-lib/setup.py')
-rw-r--r--onap-dcae-dcaepolicy-lib/setup.py3
1 files changed, 1 insertions, 2 deletions
diff --git a/onap-dcae-dcaepolicy-lib/setup.py b/onap-dcae-dcaepolicy-lib/setup.py
index 8a82d16..eed69f0 100644
--- a/onap-dcae-dcaepolicy-lib/setup.py
+++ b/onap-dcae-dcaepolicy-lib/setup.py
@@ -1,4 +1,3 @@
-# org.onap.dcae
# ================================================================================
# Copyright (c) 2017-2018 AT&T Intellectual Property. All rights reserved.
# ================================================================================
@@ -24,7 +23,7 @@ from setuptools import setup, find_packages
setup(
name='onap-dcae-dcaepolicy-lib',
description='lib of policy decorators to be used by cloudify plugins of dcae controller',
- version="2.1.0",
+ version="2.2.0",
author='Alex Shatov',
author_email="alexs@att.com",
license='Apache 2',