summaryrefslogtreecommitdiffstats
path: root/onap-dcae-dcaepolicy-lib/setup.py
diff options
context:
space:
mode:
authorAlex Shatov <alexs@att.com>2018-02-23 14:56:36 -0500
committerAlex Shatov <alexs@att.com>2018-02-23 14:56:36 -0500
commitcfdd67d316e3436fb8054e07f883eceeff5bd08c (patch)
treec8cfff66970b3029a12b9fefe789dddf7342d9b7 /onap-dcae-dcaepolicy-lib/setup.py
parentd1a814370eb3e45368af9d6a76f8ded77cca5c82 (diff)
store policies into consul-kv as <scn>:policies/
- now storing policies into consul-kv under folder <service_cmponent_name>:policies/ as items/<policy_id>=<policy_body> and event={"action": "gathered", "policies_count": 30, "timestamp": "2018-02-12T10:20:30.777Z", "update_id": "0e79edc0-6c64-425e-a618-cc13ef50cd56"}} - this data is going to be retrieved by config-binding service thru a new API http GET <CBS>/service_component_all/<service_component_name> - passing policy_body objects to plugins that consume the Policies decorators to pass to component - new decorator to delete the <service_cmponent_name>:policies/ folder in consul-kv upon uninstalling the component - sorting and merge of policy configs into application config is not removed yet - to be done later - fixed unit tests - coverage is 83% Change-Id: Ie55be9298ac7889d516a5b884a2e24ac05c65a01 Signed-off-by: Alex Shatov <alexs@att.com> Issue-ID: DCAEGEN2-347
Diffstat (limited to 'onap-dcae-dcaepolicy-lib/setup.py')
-rw-r--r--onap-dcae-dcaepolicy-lib/setup.py3
1 files changed, 1 insertions, 2 deletions
diff --git a/onap-dcae-dcaepolicy-lib/setup.py b/onap-dcae-dcaepolicy-lib/setup.py
index 0e5b2ef..8a82d16 100644
--- a/onap-dcae-dcaepolicy-lib/setup.py
+++ b/onap-dcae-dcaepolicy-lib/setup.py
@@ -24,7 +24,7 @@ from setuptools import setup, find_packages
setup(
name='onap-dcae-dcaepolicy-lib',
description='lib of policy decorators to be used by cloudify plugins of dcae controller',
- version="2.0.0",
+ version="2.1.0",
author='Alex Shatov',
author_email="alexs@att.com",
license='Apache 2',
@@ -33,7 +33,6 @@ setup(
],
keywords='onap policy dcae controller cloudify plugin',
classifiers=[
- 'Development Status :: 4 - Beta',
'Intended Audience :: Telecommunications Industry',
'Programming Language :: Python :: 2.7'
]