summaryrefslogtreecommitdiffstats
path: root/components/pm-subscription-handler/setup.py
diff options
context:
space:
mode:
authorefiacor <fiachra.corcoran@est.tech>2020-01-24 13:19:01 +0000
committerefiacor <fiachra.corcoran@est.tech>2020-02-10 15:45:13 +0000
commit8b3fc62050a344fe9a9c8909e4c672cb9aa3281d (patch)
treeaa74fef6de378a1914067cb8a3fffa3798cb6a35 /components/pm-subscription-handler/setup.py
parentbbe05d8a65ee0ac698d906b50282406bafe34f80 (diff)
Adding DB Init and setup
Signed-off-by: efiacor <fiachra.corcoran@est.tech> Change-Id: Ie32efcf007c9b6fa25b0072019f4a91a841d9d0c Issue-ID: DCAEGEN2-1828
Diffstat (limited to 'components/pm-subscription-handler/setup.py')
-rw-r--r--components/pm-subscription-handler/setup.py8
1 files changed, 6 insertions, 2 deletions
diff --git a/components/pm-subscription-handler/setup.py b/components/pm-subscription-handler/setup.py
index a4d9ada4..056a5d82 100644
--- a/components/pm-subscription-handler/setup.py
+++ b/components/pm-subscription-handler/setup.py
@@ -1,5 +1,5 @@
# ============LICENSE_START=======================================================
-# Copyright (C) 2019 Nordix Foundation.
+# Copyright (C) 2019-2020 Nordix Foundation.
# ================================================================================
# Licensed under the Apache License, Version 2.0 (the "License");
# you may not use this file except in compliance with the License.
@@ -30,5 +30,9 @@ setup(
python_requires='>=3',
install_requires=[
"requests==2.22.0",
- "tenacity==6.0.0"],
+ "tenacity==6.0.0",
+ "connexion==2.5.0",
+ "flask_sqlalchemy==2.4.1",
+ "Flask==1.1.1",
+ "psycopg2-binary==2.8.4"]
)