diff options
author | Alex Shatov <alexs@att.com> | 2018-06-21 09:19:07 -0400 |
---|---|---|
committer | Alex Shatov <alexs@att.com> | 2018-06-21 09:19:07 -0400 |
commit | d444b320dea07248dc69c81d0ce9ea5fc353e701 (patch) | |
tree | cacd244c5e2424faca5e088dc3ca3baf9afd8511 /setup.py | |
parent | c9ec231483d905f3a391c3985c2c2762344ed5c1 (diff) |
3.0.1 policy-handler - cleaning sonar smells
- no change of functionality or API
- removed the unused enum34>=1.1.6 from requirements.txt and setup.py
- refactored run_policy.sh to redirect the stdout+stderr only once
- refactoring to remove smells+vulnerability reported by sonar
-- renamed Config.config to Config.settings
-- removed the commented out code in customizer.py
-- renamed StepTimer.NEXT to StepTimer.STATE_NEXT to avoid the
naming confusion with the method StepTimer.next.
Also renamed the related StepTimer.STATE_* constants
-- refactored several functions by extracting methods to eliminate
4 out of 5 "brain-overload" smells reported by sonar
-- moved the literal string for the socket_host "0.0.0.0" to a
constant on the web-server to avoid the reported vulnerability
Change-Id: I4c7d47d41c6ecd7cb28f6704f5dad2053c1ca7d6
Signed-off-by: Alex Shatov <alexs@att.com>
Issue-ID: DCAEGEN2-515
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 3 |
1 files changed, 1 insertions, 2 deletions
@@ -23,13 +23,12 @@ from setuptools import setup setup(
name='policyhandler',
description='DCAE-Controller policy-handler to communicate with policy-engine',
- version="3.0.0",
+ version="3.0.1",
author='Alex Shatov',
packages=['policyhandler'],
zip_safe=False,
install_requires=[
"CherryPy>=15.0.0,<16.0.0",
- "enum34>=1.1.6",
"psutil>=5.4.5,<6.0.0",
"requests>=2.18.4,<3.0.0",
"websocket-client>=0.48.0,<1.0.0"
|