diff options
author | Alex Shatov <alexs@att.com> | 2018-01-10 11:00:50 -0500 |
---|---|---|
committer | Alex Shatov <alexs@att.com> | 2018-01-10 11:07:30 -0500 |
commit | 1369bea8b3c24ef063799acefbfc01659878f034 (patch) | |
tree | 95fa3e5580f62be9c1e1d630ed0c6496b9fb03a2 /setup.py | |
parent | dc5da5bf63ae4a4ac11b4b5c46407e58da16fbfe (diff) |
variable collection of policies per component
* new feature variable collection of policies per component in DCAE
* massive refactoring
* dissolved the external PolicyEngine.py into policy_receiver.py
- kept only the web-socket communication to PolicyEngine
* new /healthcheck - shows some stats of service running
* Unit Test coverage 75%
Change-Id: I816b7d5713ae0dd88fa73d3656f272b4f3e7946e
Issue-ID: DCAEGEN2-249
Signed-off-by: Alex Shatov <alexs@att.com>
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 4 |
1 files changed, 1 insertions, 3 deletions
@@ -24,16 +24,14 @@ from setuptools import setup setup(
name='policyhandler',
description='DCAE-Controller policy-handler to communicate with policy-engine',
- version="1.0.0",
+ version="2.0.0",
author='Alex Shatov',
packages=['policyhandler'],
zip_safe=False,
install_requires=[
"CherryPy>=10.2.2,<11.0",
"enum34>=1.1.6",
- "future>=0.16.0",
"requests>=2.13.0,<3.0.0",
- "six>=1.10.0",
"websocket-client>=0.40.0"
],
keywords='policy dcae controller',
|