summaryrefslogtreecommitdiffstats
path: root/clamp-policy/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'clamp-policy/setup.py')
-rw-r--r--clamp-policy/setup.py37
1 files changed, 37 insertions, 0 deletions
diff --git a/clamp-policy/setup.py b/clamp-policy/setup.py
new file mode 100644
index 0000000..de6b119
--- /dev/null
+++ b/clamp-policy/setup.py
@@ -0,0 +1,37 @@
+# ================================================================================
+# Copyright (c) 2019 Wipro Limited Intellectual Property. All rights reserved.
+# ================================================================================
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+# ============LICENSE_END=========================================================
+#
+
+"""package for clamppolicyplugin - getting policy model id from policy-engine through policy-handler"""
+
+from setuptools import setup
+
+setup(
+ name='clamppolicyplugin',
+ description='Cloudify plugin for clamp.nodes.policy node to retrieve the policy model id',
+ version="1.0.0",
+ author='Vignesh K',
+ packages=['clamppolicyplugin'],
+ install_requires=[
+ "requests>=2.11.0,<3.0.0"
+ ],
+ keywords='clamp policy model cloudify plugin',
+ classifiers=[
+ 'Development Status :: 4 - Beta',
+ 'Intended Audience :: Developers',
+ 'Programming Language :: Python :: 2.7'
+ ]
+)