summaryrefslogtreecommitdiffstats
path: root/cdap/cdapplugin/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'cdap/cdapplugin/setup.py')
-rw-r--r--cdap/cdapplugin/setup.py37
1 files changed, 37 insertions, 0 deletions
diff --git a/cdap/cdapplugin/setup.py b/cdap/cdapplugin/setup.py
new file mode 100644
index 0000000..d16667d
--- /dev/null
+++ b/cdap/cdapplugin/setup.py
@@ -0,0 +1,37 @@
+# org.onap.dcae
+# ================================================================================
+# Copyright (c) 2017 AT&T Intellectual Property. All rights reserved.
+# ================================================================================
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+# ============LICENSE_END=========================================================
+#
+# ECOMP is a trademark and service mark of AT&T Intellectual Property.
+
+import os
+from setuptools import setup, find_packages
+
+setup(
+ name = "cdapcloudify",
+ version = "14.0.2",
+ packages=find_packages(),
+ author = "Tommy Carpenter",
+ author_email = "tommy at research dot eh tee tee dot com",
+ description = ("Cloudify plugin for CDAP"),
+ license = "",
+ keywords = "",
+ url = "https://gerrit.onap.org/r/#/admin/projects/dcaegen2/platform/plugins",
+ zip_safe=False,
+ install_requires = [
+ "uuid==1.30"
+ ]
+)